Bug 54184 - Tomcat 7.0.32, IE & javascript comments - number of dashes must be even
Summary: Tomcat 7.0.32, IE & javascript comments - number of dashes must be even
Status: RESOLVED DUPLICATE of bug 53986
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Jasper (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-21 16:15 UTC by bill
Modified: 2012-11-22 08:45 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bill 2012-11-21 16:15:14 UTC
see my blog entry http://billcomer.blogspot.co.uk/2012/11/tomcat-7032-ie-javascript-comments.html for more info.

essentially with IE on tomcat 7.0.32 if you have a javascript comment
with an uneven number of dashes then it fails.

IE these are bad

<%--- a comment with three dashes ---%>
<%----- a comment with three dashes -----%>

these are good

<%-- a comment with three dashes --%>
<%---- a comment with three dashes ----%>

Previous versions of tomcat - well 7.0.29 atleast and earlier were fine.

Swapping out the jasper jars fixes the issue
Comment 1 Mark Thomas 2012-11-21 19:13:37 UTC
As an aside, swapping Jasper JAR files between version is not guaranteed to be safe. If you do that, you are on your own.

*** This bug has been marked as a duplicate of bug 53986 ***
Comment 2 bill 2012-11-22 08:45:15 UTC
Quite agree Mark,

That was just me trying to work out where the issue was.