Bug 54317 - __Random in a Loop Condition sometimes makes the thread skip the loop.
Summary: __Random in a Loop Condition sometimes makes the thread skip the loop.
Status: RESOLVED DUPLICATE of bug 54467
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.8
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-17 09:29 UTC by Vitalik
Modified: 2013-01-22 21:21 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vitalik 2012-12-17 09:29:16 UTC
If you want to repeat something a random amount of times, you should create a variable before specifying it in the "Loop Count" field of a Loop Controller, because Sometimes the loop will be skipped completely.
Comment 1 Philippe Mouawad 2012-12-19 22:34:51 UTC
Hello,
Can you clarify your problem ?
Is it a problem or not ? 

A simple test plan showing the issue is welcome.
Regards
Comment 2 Philippe Mouawad 2012-12-26 10:08:27 UTC
Closing as nothing can be done with thid report.
Feel free to reopen with more details.
Comment 3 Philippe Mouawad 2013-01-22 21:21:51 UTC

*** This bug has been marked as a duplicate of bug 54467 ***