Bug 54422 - HSSFCellStyle::setWrapText seems to be broken in 3.8
Summary: HSSFCellStyle::setWrapText seems to be broken in 3.8
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.8-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
Depends on:
Reported: 2013-01-15 18:20 UTC by littlenoodles
Modified: 2013-01-16 06:46 UTC (History)
0 users

produced with poi-3.6 (10.50 KB, application/vnd.ms-excel)
2013-01-15 18:20 UTC, littlenoodles
produced with poi-3.8 (10.50 KB, application/vnd.ms-excel)
2013-01-15 18:21 UTC, littlenoodles

Note You need to log in before you can comment on or make changes to this bug.
Description littlenoodles 2013-01-15 18:20:22 UTC
Created attachment 29854 [details]
produced with poi-3.6

I recently went from using poi-3.2 to poi-3.8, and the behavior of HSSFCellSTyle::setWrapText seems to have changed.  Excel used to auto-size the height of the row in order to display all the wrapping text the first time you opened the xls.  Now it doesn't.  If you manually resize the row height, the wrapping text shows up.

I tried backing off to poi-3.6, and setWrapText seems to work there like it used to in 3.2.

I'm attaching 2 documents - both generated with the same code, but one using poi-3.6 and one using poi-3.8.  The column headers (light gray row 8) wrap in the 3.6 version, but don't wrap in the 3.8 version.
Comment 1 littlenoodles 2013-01-15 18:21:28 UTC
Created attachment 29855 [details]
produced with poi-3.8
Comment 2 littlenoodles 2013-01-15 18:26:38 UTC
I just tried it with poi-3.9, and the wrapping column headers seem to work again.