Bug 54435 - LimitRequestBody ignores special value 0 - unlimited in mod_proxy_http
Summary: LimitRequestBody ignores special value 0 - unlimited in mod_proxy_http
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy_http (show other bugs)
Version: 2.4.3
Hardware: PC Linux
: P2 regression (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: FixedInTrunk, PatchAvailable
: 54039 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-16 14:30 UTC by Pavel Mateja
Modified: 2013-02-06 19:33 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Mateja 2013-01-16 14:30:29 UTC
Documentation "http://httpd.apache.org/docs/2.4/mod/core.html#limitrequestbody" says:
Default:	LimitRequestBody 0
..
This directive specifies the number of bytes from 0 (meaning unlimited) to 2147483647 (2GB) that are allowed in a request body.

This works in apache 2.2.
But this is not tue for proxy requests anymore. Apache 2.4 uses MAX_MEM_SPOOL instead.
I think there should be something like
if (limit && (bytes_spooled + bytes > limit)) {
in ./modules/proxy/mod_proxy_http.c on line 590
Comment 1 Ruediger Pluem 2013-01-16 15:38:32 UTC
Thanks for the patch. Committed to trunk as r1433988.
Comment 2 Ruediger Pluem 2013-01-21 16:10:45 UTC
Backport to 2.4.x as r1436443.
Comment 3 Christophe JAILLET 2013-02-06 19:33:51 UTC
*** Bug 54039 has been marked as a duplicate of this bug. ***