Bug 54787 - Read special characters like pie symbol from Microsoft Excel
Summary: Read special characters like pie symbol from Microsoft Excel
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.9-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-02 15:23 UTC by Sagar
Modified: 2015-06-01 21:25 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sagar 2013-04-02 15:23:09 UTC
I want to read special characters from excel sheet and write it to database.
But I am not able to read special characters (Mathematical Symbols like pie, square root)

Regards,
Sagar
Comment 1 Sagar 2013-04-02 15:34:44 UTC
The code is executing from Tomcat web server. 
When I tried to read it using standalone application it is working.

Please help in this.

Regards,
Sagar
Comment 2 Nick Burch 2013-04-02 17:44:54 UTC
Should work just fine...

Can you produce a unit test that shows up the problem? Are you sure your output stream + font supports the appropriate characters? Are you setting the encoding + encoding details on your output appropriately?
Comment 3 Sagar 2013-04-03 14:01:10 UTC
I have provided UTF-8 character set in Servlet, JSP, Server.xml and catalina.bat

Where else I need to provide character set?
Comment 4 Dominik Stadler 2015-06-01 21:25:53 UTC
We cannot reproduce any problem with the information currently available here, therefore resolving this as WORKSFORME, please reopen with a unit-test that shows the problem if this is still a problem for you.