Bug 54863 - Mismatched value returned by style.getBorder*()
Summary: Mismatched value returned by style.getBorder*()
Status: RESOLVED DUPLICATE of bug 55341
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.9-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-18 17:55 UTC by Jim Talbut
Modified: 2013-09-29 20:16 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Talbut 2013-04-18 17:55:51 UTC
In POI 3.8 a cell with a dotted border returns CellStyle.BORDER_DOTTED from cell.getCellStyle().getBorderBottom() when using either HSSF or XSSF.

In POI 3.9 the XSSF version returns CellSTyle.BORDER_HAIR, but the HSSF version continues to return CellStyle.BORDER_DOTTED.

The comments in CellStyle.class indicate that there is some confusion about these constants:
    /**
     * dot border
     */

    public final static short BORDER_HAIR = 0x4;

    /**
     * hair-line border
     */

    public final static short BORDER_DOTTED = 0x7;
Comment 1 Dominik Stadler 2013-09-29 20:16:09 UTC
Marking this Bug as duplicate of Bug 55341 which has a patch to test and fix this.

*** This bug has been marked as a duplicate of bug 55341 ***