Bug 54932 - Broken link to Tribes documentation
Broken link to Tribes documentation
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Documentation
7.0.39
PC Windows XP
: P2 minor (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-05-06 14:06 UTC by Konstantin Kolinko
Modified: 2013-05-15 13:17 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kolinko 2013-05-06 14:06:58 UTC
1. Go to  http://tomcat.apache.org/tomcat-7.0-doc/

2. In the menu at the left of the page, scroll down to "Apache Tomcat Development" section and click on "Tribes" link

3. The browser navigates to
http://tomcat.apache.org/tomcat-7.0-doc/tribes/index.html
which gives error 404 "Not Found".

The issue is that
- there is no "index.html" in Tribes section
- there are pages there, but all they except one are empty, containing only header and "TODO" marker
- the correct link (and the only valuable page there) is:
http://tomcat.apache.org/tomcat-7.0-doc/tribes/introduction.html

Alternatively, linking to
http://tomcat.apache.org/tomcat-7.0-doc/tribes/
will provide a listing of all pages in that directory on the server.
Comment 1 Violeta Georgieva 2013-05-06 17:41:16 UTC
(In reply to comment #0)
> - the correct link (and the only valuable page there) is:
> http://tomcat.apache.org/tomcat-7.0-doc/tribes/introduction.html
> 

+1

If we choose this option then project.xml needs also correction - "Tribes Docs Home" should point to introduction.html
Comment 2 Violeta Georgieva 2013-05-15 13:17:26 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > - the correct link (and the only valuable page there) is:
> > http://tomcat.apache.org/tomcat-7.0-doc/tribes/introduction.html
> > 
> 
> +1
> 
> If we choose this option then project.xml needs also correction - "Tribes
> Docs Home" should point to introduction.html

Fixed in trunk and 7.0.x and will be included in 7.0.41 onwards.