Bug 54988 - Error on copy/paste will not let copy anything [res_key=clipboard_node_read_error]
Summary: Error on copy/paste will not let copy anything [res_key=clipboard_node_read_e...
Status: RESOLVED DUPLICATE of bug 54504
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.9
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-17 11:19 UTC by Samuel
Modified: 2013-05-17 13:12 UTC (History)
1 user (show)



Attachments
jmx file that can reproduce the issue (3.15 KB, application/octet-stream)
2013-05-17 11:19 UTC, Samuel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel 2013-05-17 11:19:10 UTC
Created attachment 30290 [details]
jmx file that can reproduce the issue

Jmeter v2.9 will not copy any node (ex simple controller) and will show a pop up with the error [res_key=clipboard_node_read_error].

Log viewer shows:
2013/05/17 12:01:53 WARN  - jmeter.util.JMeterUtils: ERROR! Resource string not found: [clipboard_node_read_error] 

It complains about a custom made plugin that is also present in the test suite. The portion I try to copy is not even related to that node.

Attached a simple example that would fail I think the copy/paste java code has a problem when parsing the XML file. This makes the copy of any node impossible.

The only way to make it work is to delete the offending node.

txs
Comment 1 Philippe Mouawad 2013-05-17 12:09:32 UTC
Bug is in third party library and part related to core jmeter is fixed in trunk

*** This bug has been marked as a duplicate of bug 54504 ***
Comment 2 Samuel 2013-05-17 13:12:06 UTC
I am not trying to copy paste the third party node, why would jmeter still fail in that instance to copy a jmeter core node? Shouldn't it still succeed?