Bug 55341 - [PATCH] constants for HAIR and DOTTED border styles are swapped
[PATCH] constants for HAIR and DOTTED border styles are swapped
Status: RESOLVED FIXED
Product: POI
Classification: Unclassified
Component: POI Overall
3.10-dev
PC All
: P2 normal (vote)
: ---
Assigned To: POI Developers List
:
: 54863 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-08-01 21:52 UTC by vladk
Modified: 2013-09-29 20:24 UTC (History)
1 user (show)



Attachments
Patch and unit tests (10.06 KB, patch)
2013-08-01 21:52 UTC, vladk
Details | Diff
Excel file to be put into poi/test-data/spreadsheet (27.50 KB, application/vnd.ms-excel)
2013-08-01 21:53 UTC, vladk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vladk 2013-08-01 21:52:11 UTC
Created attachment 30659 [details]
Patch and unit tests

Values of constants CellStyle.BORDER_HAIR and CellStyle.BORDER_DOTTED are swapped. Patch and units tests will be attached.
Comment 1 vladk 2013-08-01 21:53:37 UTC
Created attachment 30660 [details]
Excel file to be put into poi/test-data/spreadsheet
Comment 2 vladk 2013-08-09 18:47:41 UTC
Setting cell border style to CellStyle.BORDER_DOTTED produces Excel style "hairline".
Setting cell border style to CellStyle.BORDER_HAIR produces Excel style "dotted".
The problem is also present when reading Excel files. The problem affects both XLS and XLSX files.
Comment 3 Dominik Stadler 2013-09-29 20:16:09 UTC
*** Bug 54863 has been marked as a duplicate of this bug. ***
Comment 4 Dominik Stadler 2013-09-29 20:24:39 UTC
Thanks for catching this, this is now fixed in latest trunk to be included in version 3.10.