Bug 55410 - shape of the comment box in all the remaining sheets changes to a giant Curved Arrow
Summary: shape of the comment box in all the remaining sheets changes to a giant Curve...
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.8-FINAL
Hardware: PC All
: P2 major with 6 votes (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 55409 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-13 08:07 UTC by gmzjhz
Modified: 2015-06-03 12:53 UTC (History)
1 user (show)



Attachments
Project and Description document (237.09 KB, application/x-zip-compressed)
2013-08-13 08:21 UTC, gmzjhz
Details
Potential patch (1.45 KB, patch)
2014-03-26 14:34 UTC, David North
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description gmzjhz 2013-08-13 08:07:52 UTC
We create multiple sheets and set comment in some cells in each sheet in Java file.
Then download excel and comment is displayed in a drawing object like textbox.
But when we delete one sheet in the downloaded excel, then the shape of the comment box in all the remaining sheets changes to a giant Curved Arrow.

In the attachment:
1. We do not provide lib .jar files due to .jar files are huge.
2. We have provided one document to explain the details of issue and one excel which is automatically generated after run our project in BugTest project .
3. You can try to delete one sheet in excel, and will find out the shape of the comment box in all the remaining sheets changes to a giant Curved Arrow.
Comment 1 gmzjhz 2013-08-13 08:21:38 UTC
Created attachment 30726 [details]
Project and Description document
Comment 2 Nick Burch 2013-08-13 12:11:54 UTC
*** Bug 55409 has been marked as a duplicate of this bug. ***
Comment 3 David North 2014-03-26 14:34:35 UTC
Created attachment 31440 [details]
Potential patch

We came across similar issues. This seems to affect Excel versions >= 2010. 2010 removes the comment border and background fill after re-saving the file.

It seems as though the ID used for the comment shape type in the VML drawing file has significance to Excel. At any rate, the attached patch fixes the problem for us.
Comment 4 David North 2015-06-03 12:53:02 UTC
Fixed in SVN r1683315