Bug 55416 - XSLFTable corrupting the powerpoint slide
Summary: XSLFTable corrupting the powerpoint slide
Alias: None
Product: POI
Classification: Unclassified
Component: XSLF (show other bugs)
Version: 3.9-FINAL
Hardware: PC Linux
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
Depends on:
Reported: 2013-08-14 14:19 UTC by TRSP
Modified: 2015-10-29 01:25 UTC (History)
0 users

Jars i included (34.20 KB, image/pjpeg)
2013-08-14 14:19 UTC, TRSP

Note You need to log in before you can comment on or make changes to this bug.
Description TRSP 2013-08-14 14:19:29 UTC
Created attachment 30731 [details]
Jars i included

I'm using Apache POI 3.9 to generate Power Point slide (PPTX) file. Everything works fine when i execute in Windows machine but not in Linux machine. The table creation using XSLFTable inside a PPT slide is causing the issue. As suggested in other forum i tried including all POI3.9 jars along with ooxml-schemas-1.1.jar (full version - around 14MB). Also i've tried excluding poi-ooxml-schemas.jar among all the jars. Nothing seems working. PPTx is getting generated but when i try to open the file, it says "File has been corrupted". If i comment out "table creation set of code", PPTX file is opening perfectly. 

Can somebody throw some highlight on this issue?
Comment 1 Andreas Beeker 2015-10-29 01:25:03 UTC
I'm closing this entry now, as it's already quite old and there have been a lot 
of changes in X/HSLF in the meantime.
If you are still facing this issue with a current version of POI, please add a 
full example (... not just a screenshot of your jars).