Bug 55440 - ComboStringEditor should allow tags to be language dependent
ComboStringEditor should allow tags to be language dependent
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.9
PC Windows XP
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-08-16 22:22 UTC by Sebb
Modified: 2013-08-20 15:27 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2013-08-16 22:22:08 UTC
The ComboStringEditor can display a list of fixed strings from which the user can make a selection. It would be useful if the strings could be derived from resources so they could be translated for display.

If the user provides a ResourceBundle, then the ComboStringEditor (CSE) can translate any tag entries before storing them in the model. On input, CSE needs to check if the selected index corresponds to one of the translated tags and if so, return the tag; otherwise return the actual string as it must have been entered by the user.

Direct display of a string is a bit trickier; only strings which match one of the tag values should be translated.
Comment 1 Sebb 2013-08-16 23:29:38 UTC
URL: http://svn.apache.org/r1514923
Log:
ComboStringEditor should allow tags to be language dependent
Bugzilla Id: 55440

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/testbeans/gui/ComboStringEditor.java
    jmeter/trunk/src/core/org/apache/jmeter/testbeans/gui/TypeEditor.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Sebb 2013-08-19 22:12:51 UTC
The changes have broken the behaviour; it does not save edit changes when leaving the screen. See Bug 55432 for further details.

The details are saved OK if one leaves the field before leaving the screen.
Comment 3 Sebb 2013-08-20 15:27:40 UTC
That was not the cause of the bug, probably Bug 55103 is the cause.