Bug 55773 - NullPointerException in ResponseAssertion if "JMeter Variable" is not existing
Summary: NullPointerException in ResponseAssertion if "JMeter Variable" is not existing
Status: RESOLVED DUPLICATE of bug 55694
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.8
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-13 10:11 UTC by christopher.roscoe
Modified: 2013-11-15 20:50 UTC (History)
1 user (show)



Attachments
Testcase to reproduce (4.22 KB, text/plain)
2013-11-13 10:11 UTC, christopher.roscoe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christopher.roscoe 2013-11-13 10:11:32 UTC
Created attachment 31041 [details]
Testcase to reproduce

Apache JMeter Version 2.10 r1533061

I was adding a Reponse Assertion element to my existing JDBC-Sampler and ran my test.
If failed with "Assertion failure message: java.lang.NullPointerException".
In the log i saw this message.

2013/11/13 10:47:33 ERROR - jmeter.threads.JMeterThread: Exception processing Assertion  java.lang.NullPointerException
	at org.apache.jmeter.assertions.ResponseAssertion.evaluateResponse(ResponseAssertion.java:337)
	at org.apache.jmeter.assertions.ResponseAssertion.getResult(ResponseAssertion.java:201)
	at org.apache.jmeter.threads.JMeterThread.processAssertion(JMeterThread.java:706)
	at org.apache.jmeter.threads.JMeterThread.checkAssertions(JMeterThread.java:677)
	at org.apache.jmeter.threads.JMeterThread.process_sampler(JMeterThread.java:440)
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:257)
	at java.lang.Thread.run(Thread.java:662)


Only with debugging JMeter i found out, that i had a typo in the "JMeter Variable" parameter.

See the attached testcase to reproduce the exception.

I would expect an errormessage, that tells me exactly what is wrong.
e.g. "variable x not found in current scope"
Comment 1 Philippe Mouawad 2013-11-15 20:50:55 UTC
See duplicate bug which scope has been enlarged to better handle scope variable

*** This bug has been marked as a duplicate of bug 55694 ***