Bug 55946 - Add sample filter for serving pre-compressed files by merely adding "Content-Encoding" to response headers
Summary: Add sample filter for serving pre-compressed files by merely adding "Content-...
Status: RESOLVED WONTFIX
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Examples (show other bugs)
Version: 8.0.x-trunk
Hardware: PC Mac OS X 10.4
: P2 enhancement (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
: 55945 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-01 18:35 UTC by Christopher Schultz
Modified: 2014-01-14 15:22 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Schultz 2014-01-01 18:35:40 UTC
Certain pre-compressed resources need only Content-Encoding:gzip set in output headers (e.g. .svgz files).

Ref: http://markmail.org/thread/oatgj63lrgc4kvh6

In that thread, markt proposed a Filter that could be used as a basis.
Comment 1 Mark Thomas 2014-01-14 12:12:45 UTC
*** Bug 55945 has been marked as a duplicate of this bug. ***
Comment 2 Mark Thomas 2014-01-14 12:17:34 UTC
I don't think there is enough demand for this feature to add an example filter to the distribution. My example filter [1] isn't going anywhere. A better solution might be to create an area on the wiki (I though we already had one but couldn't find it) for sample code like this.
Comment 3 Christopher Schultz 2014-01-14 15:22:11 UTC
Okay. Your filter did have a flaw in it that needed to be corrected. I'll see if I can find a home for it on the Wiki.