Bug 56080 - Conversion error com.thoughtworks.xstream.converters.ConversionException with Java 8 Early Access Build
Summary: Conversion error com.thoughtworks.xstream.converters.ConversionException with...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: Nightly (Please specify date)
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 56602 56875 56904 56941 57134 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-28 20:45 UTC by Milamber
Modified: 2014-10-23 11:08 UTC (History)
6 users (show)



Attachments
Simple test script (5.06 KB, text/plain)
2014-01-28 20:45 UTC, Milamber
Details
JMeter log file with error messages (9.55 KB, text/plain)
2014-01-28 20:46 UTC, Milamber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milamber 2014-01-28 20:45:25 UTC
Created attachment 31265 [details]
Simple test script

With Java 8 EA builds (2014/01/25), JMeter trunk fails to load a simple test script with a Constant Throughput Timer element.

With Java 6 or 7 the issue doesn't exists.

Perhaps is a Java 8 bug ou Xstream bug.

Error is:

2014/01/28 20:37:46 ERROR - jmeter.save.SaveService: Conversion error com.thoughtworks.xstream.converters.ConversionException: -1 : -1
---- Debugging information ----
message             : -1
cause-exception     : java.lang.ArrayIndexOutOfBoundsException
cause-message       : -1
class               : org.apache.jmeter.testelement.property.DoubleProperty
required-type       : org.apache.jmeter.testelement.property.DoubleProperty
converter-type      : com.thoughtworks.xstream.converters.reflection.ReflectionConverter
path                : /jmeterTestPlan/hashTree/hashTree/hashTree/ConstantThroughputTimer/doubleProp/name
line number         : 32
class[1]            : org.apache.jmeter.timers.ConstantThroughputTimer
converter-type[1]   : org.apache.jmeter.save.converters.TestElementConverter
class[2]            : org.apache.jorphan.collections.ListedHashTree
converter-type[2]   : org.apache.jmeter.save.converters.HashTreeConverter
Comment 1 Milamber 2014-01-28 20:46:51 UTC
Created attachment 31266 [details]
JMeter log file with error messages
Comment 2 Philippe Mouawad 2014-01-28 20:51:57 UTC
There is a newer XStream library, could you make a test with it ?

http://jira.codehaus.org/browse/XSTR-746
Comment 3 Milamber 2014-01-29 07:38:06 UTC
Fixed with xstream upgrade to 1.4.6

URL: http://svn.apache.org/r1562373
Log:
Conversion error com.thoughtworks.xstream.converters.ConversionException with Java 8 Early Access Build
Updated to xstream 1.4.6 (from 1.4.4)
Bugzilla Id: 56080

Added:
    jmeter/trunk/licenses/bin/xstream-1.4.6.txt   (contents, props changed)
      - copied, changed from r1562371, jmeter/trunk/licenses/bin/xstream-1.4.4.txt
Removed:
    jmeter/trunk/licenses/bin/xstream-1.4.4.txt
Modified:
    jmeter/trunk/build.properties
    jmeter/trunk/eclipse.classpath
    jmeter/trunk/lib/   (props changed)
    jmeter/trunk/lib/aareadme.txt
    jmeter/trunk/res/maven/ApacheJMeter_parent.pom
    jmeter/trunk/xdocs/changes.xml
Comment 4 Nikolai Grigoriev 2014-06-06 22:07:26 UTC
*** Bug 56602 has been marked as a duplicate of this bug. ***
Comment 5 Sebb 2014-08-20 15:49:27 UTC
*** Bug 56875 has been marked as a duplicate of this bug. ***
Comment 6 Philippe Mouawad 2014-09-06 09:47:33 UTC
*** Bug 56904 has been marked as a duplicate of this bug. ***
Comment 7 UbikLoadPack support 2014-09-10 09:19:56 UTC
*** Bug 56941 has been marked as a duplicate of this bug. ***
Comment 8 Philippe Mouawad 2014-10-23 11:08:39 UTC
*** Bug 57134 has been marked as a duplicate of this bug. ***