Bug 56118 - File uploads fail every other attempt using timers
Summary: File uploads fail every other attempt using timers
Status: RESOLVED DUPLICATE of bug 56119
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: Macintosh All
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-07 17:08 UTC by oliver lloyd
Modified: 2014-02-08 17:56 UTC (History)
1 user (show)



Attachments
problem jmx (36.33 KB, text/plain)
2014-02-07 17:08 UTC, oliver lloyd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oliver lloyd 2014-02-07 17:08:16 UTC
Created attachment 31291 [details]
problem jmx

This is a fairly impossible problem but I thought I'd raise it in case it supports something you've already seem. 

In the attached plan, if I run it without a timer it is successful for each request. However, if I enable the timer the the first upload request works but the second fails, then the third works, and the forth fails, etc...

The only difference is enabling and disabling the timer.

Unfortunately, I can't actually give you a working jmx - the attached will always fail but hopefully it is still useful.

Failure is:
org.apache.http.NoHttpResponseException: The target server failed to respond

Success:
204 - blank response


The type of timer makes no difference.

The value in the timer DOES make a difference. 100ms and + = problem, 30ms = no problem.

The request I am making to S3 is valid, were it not I would get an error response. In this case I get NoHTTPResponse.
Comment 1 Philippe Mouawad 2014-02-08 17:56:39 UTC

*** This bug has been marked as a duplicate of bug 56119 ***