Bug 56150 - On using scroll, the element list for thread group , the list shows triangle image and no data/elements.
Summary: On using scroll, the element list for thread group , the list shows triangle ...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: PC All
: P2 normal (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 58114 59878 60807 62219 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-18 12:08 UTC by Abhilash Alwandi
Modified: 2018-03-31 11:54 UTC (History)
5 users (show)



Attachments
Empty list on scrolling the element list (107.27 KB, image/png)
2014-02-18 12:08 UTC, Abhilash Alwandi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Abhilash Alwandi 2014-02-18 12:08:41 UTC
Created attachment 31318 [details]
Empty list on scrolling the element list

On using scroll on the elements list (the element list for thread group) the list shows triangle image and no data/elements will be there until we click outside of the list.

Steps to reproduce:
When user add the thread group.
1. User try to add any elements for that thread group.
2. Hold on the list by hover the mouse on the list.
3. Scroll the mouse wheel.
4. The triangle shaped image is displayed in the list.

For any of the list it is occurring.
Comment 1 Milamber 2014-02-18 18:49:54 UTC
Confirm bug. Same on Linux.

Jmeter.log error:

2014/02/18 18:48:40 ERROR - jmeter.JMeter: Uncaught exception:  java.lang.ArrayIndexOutOfBoundsException: -36
        at org.apache.jorphan.gui.MenuScroller.refreshMenu(MenuScroller.java:552)
        at org.apache.jorphan.gui.MenuScroller.access$300(MenuScroller.java:55)
        at org.apache.jorphan.gui.MenuScroller$MouseScrollListener.mouseWheelMoved(MenuScroller.java:578)
        at java.awt.Component.processMouseWheelEvent(Component.java:6376)
        at java.awt.Component.processEvent(Component.java:6060)
        at java.awt.Container.processEvent(Container.java:2045)
        at java.awt.Component.dispatchEventImpl(Component.java:4649)
        at java.awt.Container.dispatchEventToSelf(Container.java:2127)
        at java.awt.Component.dispatchMouseWheelToAncestor(Component.java:4801)
        at java.awt.Component.dispatchEventImpl(Component.java:4533)
        at java.awt.Container.dispatchEventImpl(Container.java:2103)
        at java.awt.Component.dispatchEvent(Component.java:4475)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4633)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4326)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4227)
        at java.awt.Container.dispatchEventImpl(Container.java:2089)
        at java.awt.Window.dispatchEventImpl(Window.java:2587)
        at java.awt.Component.dispatchEvent(Component.java:4475)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:675)
        at java.awt.EventQueue.access$300(EventQueue.java:96)
        at java.awt.EventQueue$2.run(EventQueue.java:634)
        at java.awt.EventQueue$2.run(EventQueue.java:632)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:108)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:119)
        at java.awt.EventQueue$3.run(EventQueue.java:648)
        at java.awt.EventQueue$3.run(EventQueue.java:646)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:108)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:645)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
Comment 2 Philippe Mouawad 2016-07-31 18:53:40 UTC
*** Bug 59878 has been marked as a duplicate of this bug. ***
Comment 3 Philippe Mouawad 2016-07-31 18:53:51 UTC
*** Bug 58114 has been marked as a duplicate of this bug. ***
Comment 4 UbikLoadPack support 2017-03-02 20:36:22 UTC
*** Bug 60807 has been marked as a duplicate of this bug. ***
Comment 5 Philippe Mouawad 2018-03-26 12:53:09 UTC
*** Bug 62219 has been marked as a duplicate of this bug. ***
Comment 6 Felix Schumacher 2018-03-26 16:58:11 UTC
Will be fixed in JMeter v4.1

Date: Mon Mar 26 16:56:06 2018
New Revision: 1827774

URL: http://svn.apache.org/viewvc?rev=1827774&view=rev
Log:
Keep the index right, when scrolling through the menu items.

Bugzilla Id: 56150

Modified:
    jmeter/trunk/src/jorphan/org/apache/jorphan/gui/MenuScroller.java
    jmeter/trunk/xdocs/changes.xml