Bug 56282 - org.openxmlformats.schemas.drawingml.x2006.main.STTextFontAlignType missing in poi-ooxml-schemas.jar
Summary: org.openxmlformats.schemas.drawingml.x2006.main.STTextFontAlignType missing i...
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: 3.10-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-19 10:24 UTC by Marco Lehmann-Mörz
Modified: 2016-07-24 10:47 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Lehmann-Mörz 2014-03-19 10:24:50 UTC
org.openxmlformats.schemas.drawingml.x2006.main.STTextFontAlignType and other enclosing types are missing.
Other types with Factory (and Enum) are there, such as org.openxmlformats.schemas.drawingml.x2006.main.STTextStrikeType.
Comment 1 Nick Burch 2014-03-19 10:30:21 UTC
See http://poi.apache.org/faq.html#faq-N10025 for details of how the smaller poi-ooxml-schemas jar gets generated, and what is needed to get more classes included in it
Comment 2 Marco Lehmann-Mörz 2014-03-19 10:39:20 UTC
(In reply to Nick Burch from comment #1)
> See http://poi.apache.org/faq.html#faq-N10025 for details of how the smaller
> poi-ooxml-schemas jar gets generated, and what is needed to get more classes
> included in it

Thanks for your answer.

The problem is that 

STTextFontAlignType$Enum.class (which is there) won't work without STTextFontAlignType.class (which is missing).
Comment 3 Nick Burch 2014-03-19 11:12:54 UTC
As the FAQ states, if something is missing, we need a unit test that uses the missing part, then it'll get included in future. Bonus marks if the unit test checks something useful :)
Comment 4 Marco Lehmann-Mörz 2014-03-19 14:00:31 UTC
(In reply to Nick Burch from comment #3)
> As the FAQ states, if something is missing, we need a unit test that uses
> the missing part, then it'll get included in future. Bonus marks if the unit
> test checks something useful :)

I think we don't understand each other:

If STTextFontAlignType$Enum.class is included, STTextFontAlignType.class MUST be included for the very same reason(s).

What I try to achieve:

We have an Eclipse RCP application where we need to create OOXML files.
I want to build an OSGi bundle / Eclipse Plug-in that contains org.apache.poi + ooxml-extensions.
To compile all classes and build a proper bundle I need poi-ooxml-schemas.jar (which I do reference in my maven/tycho build).
The compilation fails with complaints about the missing class I mentioned above.


Unfortunately, I already deleted my experiment and switched back to my working version 3.9. :-(
Comment 5 Dominik Stadler 2016-07-24 10:47:34 UTC
It seems current builds do have this file included correctly, therefore I am closing this as WORKSFORME, please reopen if this is still a problem for you with version 3.15-beta2 or newer of POI.

$ unzip -l build/dist/maven/poi-ooxml-schemas/poi-ooxml-schemas-3.15-beta3.jar | grep STTextFontAlign
     1464  2016-07-17 12:15   org/openxmlformats/schemas/drawingml/x2006/main/STTextFontAlignType$Enum.class
     5377  2016-07-17 12:15   org/openxmlformats/schemas/drawingml/x2006/main/STTextFontAlignType$Factory.class
     1707  2016-07-17 12:15   org/openxmlformats/schemas/drawingml/x2006/main/STTextFontAlignType.class
      417  2016-07-17 12:15   org/openxmlformats/schemas/drawingml/x2006/main/impl/STTextFontAlignTypeImpl.class