Bug 56349 - "summary" is a bad name for a Generate Summary Results component
Summary: "summary" is a bad name for a Generate Summary Results component
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: All All
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-04 16:56 UTC by gobsmack
Modified: 2014-04-16 20:04 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gobsmack 2014-04-04 16:56:50 UTC
I had a Generate Summary Results component named "summary". It worked fine when run from the GUI, but when run from the command line, the number of requests reported were double the actual number. Renaming the Generate Summary Reports component fixed the problem.

I assume this is a bug because JMeter behaves differently depending on whether the test is run from the GUI or the command line.

Please at least include some notes in the Generate Summary Reports reference information about "summary" being a bad name.

Thanks
Comment 1 Philippe Mouawad 2014-04-04 21:23:05 UTC
Hello,
> the number of requests reported were double the actual number. Renaming the Generate Summary Reports component fixed the problem.

Could you show your test plan and what is reported from GUI vs NON GUI run ?

Thank you
Comment 2 Philippe Mouawad 2014-04-16 20:04:16 UTC
Date: Wed Apr 16 20:03:35 2014
New Revision: 1588051

URL: http://svn.apache.org/r1588051
Log:
Bug 56349 - "summary" is a bad name for a Generate Summary Results component
Clarify documentation
Bugzilla Id: 56349

Modified:
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 3 Philippe Mouawad 2014-04-16 20:04:37 UTC
Thanks for report.
This is by design, I clarified documentation.