Bug 56561 - NoSuchElementException on empty attribute in Validator$ValidateVisitor.getJspAttribute(Validator.java:1385)
NoSuchElementException on empty attribute in Validator$ValidateVisitor.getJsp...
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Jasper
6.0.41
PC Linux
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
: 56610 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-05-26 05:14 UTC by Alex Panchenko
Modified: 2014-06-10 09:54 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Panchenko 2014-05-26 05:14:48 UTC
root cause
java.util.NoSuchElementException
	java.util.ArrayList$Itr.next(ArrayList.java:834)
	org.apache.jasper.compiler.Validator$ValidateVisitor.getJspAttribute(Validator.java:1385)
	org.apache.jasper.compiler.Validator$ValidateVisitor.visit(Validator.java:772)
	org.apache.jasper.compiler.Node$UninterpretedTag.accept(Node.java:1251)
	org.apache.jasper.compiler.Node$Nodes.visit(Node.java:2377)
	org.apache.jasper.compiler.Node$Visitor.visitBody(Node.java:2429)
	org.apache.jasper.compiler.Validator$ValidateVisitor.visit(Validator.java:779)
	org.apache.jasper.compiler.Node$UninterpretedTag.accept(Node.java:1251)
	org.apache.jasper.compiler.Node$Nodes.visit(Node.java:2377)
	org.apache.jasper.compiler.Node$Visitor.visitBody(Node.java:2429)
	org.apache.jasper.compiler.Validator$ValidateVisitor.visit(Validator.java:529)
	org.apache.jasper.compiler.Node$JspRoot.accept(Node.java:564)
	org.apache.jasper.compiler.Node$Nodes.visit(Node.java:2377)
	org.apache.jasper.compiler.Node$Visitor.visitBody(Node.java:2429)
	org.apache.jasper.compiler.Node$Visitor.visit(Node.java:2435)
	org.apache.jasper.compiler.Node$Root.accept(Node.java:474)
	org.apache.jasper.compiler.Node$Nodes.visit(Node.java:2377)
	org.apache.jasper.compiler.Validator.validateExDirectives(Validator.java:1841)
	org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:217)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:353)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:340)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:657)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:357)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
...

It fails on e.g. on the following line:
<body ui-view=""></body>

These changes happened in bug 56334.
Comment 1 Violeta Georgieva 2014-05-26 10:04:17 UTC
Thanks for the report. 
This has been fixed in trunk for 8.0.9 and in 7.0.x for 7.0.55 onwards.
The fix is proposed for Tomcat 6.
Comment 2 Alex Panchenko 2014-05-27 04:38:41 UTC
Thanks for applying a fix.
Would it make sense to revoke the recent releases and make a new ones with the fix soon?
Comment 3 Mark Thomas 2014-05-27 09:22:39 UTC
We don't revoke releases, we just produce a new release.

How quickly the next set of releases happens depends on a number of factors. I was planning another 8.0.x shortly anyway to try and get back to a monthly release cycle. I can also do 6.0.x if necessary. It is always a balancing act between waiting to see if further issues emerge and getting another release out. At this point, I think it probably makes sense to wait a little longer. I'll aim to do a new 6.0.x release shortly after the next 8.0.x release.
Comment 4 Violeta Georgieva 2014-05-27 17:35:54 UTC
I also plan another 7.0.x release at the beginning of the next month.
Comment 5 Violeta Georgieva 2014-05-27 17:53:24 UTC
This has been fixed in 6.0.x for 6.0.42 onwards.
Comment 6 Mark Thomas 2014-06-10 09:54:51 UTC
*** Bug 56610 has been marked as a duplicate of this bug. ***