Bug 56691 - Synchronizing Timer : Add timeout on waiting
Summary: Synchronizing Timer : Add timeout on waiting
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 53501 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-03 01:59 UTC by alvin
Modified: 2014-07-06 13:14 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alvin 2014-07-03 01:59:35 UTC
is it possible to add a timeout within synchronizing timer?

e.g.
if groupsize is set to 5 users, in a scenario where 1 of the thread is having problem or blocked for whatever reason, the rest of the threads should not wait indefinitely and hold up the entire testing. 

let user choose to enter a timeout period and either continue executing the test plan with the rest of the threads and report error, or reset the error thread in some ways.
Comment 1 Philippe Mouawad 2014-07-05 14:23:13 UTC
Date: Sat Jul  5 14:20:27 2014
New Revision: 1608020

URL: http://svn.apache.org/r1608020
Log:
Bug 56691 - Synchronizing Timer : Add timeout on waiting
Bugzilla Id: 56691

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/timers/SyncTimer.java
    jmeter/trunk/src/components/org/apache/jmeter/timers/SyncTimerBeanInfo.java
    jmeter/trunk/src/components/org/apache/jmeter/timers/SyncTimerResources.properties
    jmeter/trunk/src/components/org/apache/jmeter/timers/SyncTimerResources_fr.properties
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml


Date: Sat Jul  5 14:22:23 2014
New Revision: 1608021

URL: http://svn.apache.org/r1608021
Log:
Bug 56691 - Synchronizing Timer : Add timeout on waiting
Bugzilla Id: 56691

Added:
    jmeter/trunk/docs/images/screenshots/timers/sync_timer.png   (with props)
Modified:
    jmeter/trunk/xdocs/images/screenshots/timers/sync_timer.png
Comment 3 Philippe Mouawad 2014-07-05 14:25:39 UTC
Feature has been implemented.
Your tests and feedback are welcome on this.
You can test nightly build :
http://jmeter.apache.org/nightly.html

Read carefully:
 Installing JMeter runtime
Download the _bin and _lib files
Unpack the archives into the same directory structure
The other archives are not needed to run JMeter. 

Regards
@philmdot
Comment 4 Philippe Mouawad 2014-07-06 13:14:03 UTC
*** Bug 53501 has been marked as a duplicate of this bug. ***