Bug 56731 - EL-Expression with escaped single quote leads to ELException
Summary: EL-Expression with escaped single quote leads to ELException
Status: RESOLVED DUPLICATE of bug 56334
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Jasper (show other bugs)
Version: 7.0.54
Hardware: PC All
: P2 regression (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-16 19:47 UTC by Christof Luick
Modified: 2014-07-17 11:17 UTC (History)
0 users



Attachments
Error page with stack trace from tomcat (8.61 KB, text/html)
2014-07-16 19:47 UTC, Christof Luick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christof Luick 2014-07-16 19:47:18 UTC
Created attachment 31822 [details]
Error page with stack trace from tomcat

Hi Folks,

the following line in an 2.2-XML-JSP worked in Tomcat 7.0.39 but triggers an ELException in Tomcat 7.0.54 (see attachment for details):

<div title="${empty myVar ? '\'in quotes\'' : ''}">test</div>

I seems that the expression "'\'test\''" leads to the the problem because including it in parenthesis solves the problem in 7.0.54:

<div title="${empty myVar ? ('\'in quotes\'') : ''}">test</div>

The problem is that we have a lot of similar expressions containing escaped single quotes in our webapp.

Thanks for your help,
Christof Luick.
Comment 1 Konstantin Kolinko 2014-07-17 11:17:30 UTC
The issue is known and already fixed and mentioned in changelog.
The sample works with the current tc7.0.x

*** This bug has been marked as a duplicate of bug 56334 ***