Bug 56811 - "Start Next Thread Loop" in Result Status Action Handler or on Thread Group and "Go to next Loop iteration" in Test Action behave incorrectly with TransactionController that has "Generate Parent Sampler" checked
Summary: "Start Next Thread Loop" in Result Status Action Handler or on Thread Group a...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.9
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-04 14:23 UTC by Bernhard
Modified: 2014-10-26 13:18 UTC (History)
3 users (show)



Attachments
test and result (4.62 KB, application/x-zip-compressed)
2014-08-04 14:23 UTC, Bernhard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard 2014-08-04 14:23:58 UTC
Created attachment 31872 [details]
test and result

My example Test Plan contains (simplyfied):
Thread Group (3 Iterations)
	Interleave Controller
		Transaction Controller 1 (Generate Parent)
			Transaction Controller (Generate Parent)
				Sampler 1
				Test Action - Start Next Iteration
				Sampler 2
		Transaction Controller 2 (Generate Parent)
			Transaction Controller
				Sampler 1
				Sampler 2
				
The result is:
TC 1
TC 1
	Sampler 1
	Sampler 2
TC 2
	Sampler 1
	Sampler 2
	
So first the Test Action prevents the Transaction Controller from "collecting" any data (no children in Tree View Listener) and then doesn't process at all!
Same goes for Result Status Action Handler.

The example and the result are attached.
Comment 1 Bernhard 2014-08-04 14:31:20 UTC
Also notice that the Interleave Controller doesn't work properly when Test Action stops the iteration.
Comment 2 Philippe Mouawad 2014-10-11 21:47:02 UTC
*** Bug 53768 has been marked as a duplicate of this bug. ***
Comment 3 Philippe Mouawad 2014-10-25 15:06:15 UTC
Hello,
Thanks for report.
I further analyzed your report, in fact the problem is located in Transaction Controller and only when Generate Parent Sampler is checked.
So I renamed the bug and will try to fix it.

If I missed something in your report let me know.
Thanks
Regards
Philippe
Comment 4 Philippe Mouawad 2014-10-26 13:18:56 UTC
Date: Sun Oct 26 13:18:18 2014
New Revision: 1634323

URL: http://svn.apache.org/r1634323
Log:
Bug 56811 - "Start Next Thread Loop" in Result Status Action Handler or on Thread Group and "Go to next Loop iteration" in Test Action behave incorrectly with TransactionController that has "Generate Parent Sampler" checked
Bugzilla Id: 56811

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/control/TransactionController.java
    jmeter/trunk/xdocs/changes.xml