Bug 56875 - Conversion error
Summary: Conversion error
Status: RESOLVED DUPLICATE of bug 56080
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-20 14:59 UTC by mirko.ebert
Modified: 2014-08-20 16:14 UTC (History)
0 users



Attachments
jmeter log file (9.91 KB, text/plain)
2014-08-20 14:59 UTC, mirko.ebert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mirko.ebert 2014-08-20 14:59:04 UTC
Created attachment 31935 [details]
jmeter log file

Every thing works fine under Java 7. With Java 8, I run into problems. I have the same problem under current Linux distributions. I use following plugin: JMeterPlugins-ExtrasLibs-1.1.3



Test plan:
<?xml version="1.0" encoding="UTF-8"?>
<jmeterTestPlan version="1.2" properties="2.6" jmeter="2.11 r1554548">
  <hashTree>
    <TestPlan guiclass="TestPlanGui" testclass="TestPlan" testname="Testplan" enabled="true">
      <stringProp name="TestPlan.comments"></stringProp>
      <boolProp name="TestPlan.functional_mode">false</boolProp>
      <boolProp name="TestPlan.serialize_threadgroups">false</boolProp>
      <elementProp name="TestPlan.user_defined_variables" elementType="Arguments" guiclass="ArgumentsPanel" testclass="Arguments" testname="Benutzer definierte Variablen" enabled="true">
        <collectionProp name="Arguments.arguments"/>
      </elementProp>
      <stringProp name="TestPlan.user_define_classpath"></stringProp>
      <collectionProp name="TestPlan.thread_groups"/>
    </TestPlan>
    <hashTree>

....


           <ThroughputController guiclass="ThroughputControllerGui" testclass="ThroughputController" testname="Durchsatz-Controller" enabled="true">
              <intProp name="ThroughputController.style">1</intProp>
              <boolProp name="ThroughputController.perThread">false</boolProp>
              <intProp name="ThroughputController.maxThroughput">1</intProp>
              <FloatProperty>
                <name>ThroughputController.percentThroughput</name>
                <value>20.0</value>
                <savedValue>0.0</savedValue>
              </FloatProperty>
            </ThroughputController>
            <hashTree>
              <GenericController guiclass="LogicControllerGui" testclass="GenericController" testname="checkout" enabled="true"/>
Comment 1 mirko.ebert 2014-08-20 15:00:33 UTC
The test plan snippet is the error line from meter log.
Comment 2 Sebb 2014-08-20 15:49:27 UTC
Try upgrading XStream to 1.4.6 or 1.4.7

*** This bug has been marked as a duplicate of bug 56080 ***
Comment 3 mirko.ebert 2014-08-20 16:14:18 UTC
It works now. THX