Bug 56909 - Failed to create poller with specified size of -1
Summary: Failed to create poller with specified size of -1
Status: RESOLVED DUPLICATE of bug 56910
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Connectors (show other bugs)
Version: trunk
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-04 04:11 UTC by sunqi
Modified: 2014-09-04 09:31 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sunqi 2014-09-04 04:11:27 UTC
set maxConnections="-1" with the APR connector.

tomcat start fail,the error msg is:

 "org.apache.tomcat.util.net.AprEndpoint allocatePoller
Failed to create poller with specified size of -1"


           // Single poller by default
            int defaultPollerSize = getMaxConnections();

            if ((OS.IS_WIN32 || OS.IS_WIN64) && (defaultPollerSize > 1024)) {
                // The maximum per poller to get reasonable performance is 1024
                // Adjust poller size so that it won't reach the limit. This is
                // a limitation of XP / Server 2003 that has been fixed in
                // Vista / Server 2008 onwards.
                actualPollerSize = 1024;
            } else {
                actualPollerSize = defaultPollerSize;
            }
Comment 1 Konstantin Kolinko 2014-09-04 09:31:08 UTC

*** This bug has been marked as a duplicate of bug 56910 ***