Bug 56941 - Test Plan broken after use throughtput controler with Java 8
Summary: Test Plan broken after use throughtput controler with Java 8
Status: RESOLVED DUPLICATE of bug 56080
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: PC All
: P2 blocker (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-10 09:10 UTC by Tomasz Szycher
Modified: 2014-09-10 16:12 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Szycher 2014-09-10 09:10:43 UTC
How to reproduce:
in test plan create thread group next under it throughput controller an some sample.
After save whole test plan in JMX is broken. throughput controller is wrongly saved in jmx file. 
When I trying to close JMeter, information about unsaved changes is show, but after click on yes (save changes) nothing happen. 
The real problem is that test plan is broken and data inside lost.

After investigation I found the reason: Java 8.
After change java to Java 7 error doesn't occur.
Comment 1 UbikLoadPack support 2014-09-10 09:19:56 UTC
Hello,
Issue is fixed in Nightly build.
You should check it out here:
http://jmeter.apache.org/nightly.html
 Installing JMeter runtime
Download the _bin and _lib files
Unpack the archives into the same directory structure
The other archives are not needed to run JMeter.

*** This bug has been marked as a duplicate of bug 56080 ***
Comment 2 Sebb 2014-09-10 16:12:36 UTC
Alternatively, just update the XStream jar to 1.4.6