Bug 57005 - maven build for jdbc-pool broken with Java 8 because of javadoc problems
maven build for jdbc-pool broken with Java 8 because of javadoc problems
Status: RESOLVED FIXED
Product: Tomcat Modules
Classification: Unclassified
Component: jdbc-pool
unspecified
All All
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-09-23 11:44 UTC by Pierre Viret
Modified: 2014-10-12 10:40 UTC (History)
0 users



Attachments
proposed patch which fixes the javadoc errors (9.54 KB, patch)
2014-10-07 17:41 UTC, Pierre Viret
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Viret 2014-09-23 11:44:51 UTC
The maven build for jdbc-pool crashes while creating the javadoc with following error:
/Users/viretp/Dev/apache/tomcat/sandbox/trunk-maven-layout/modules/jdbc-pool/src/main/java/org/apache/tomcat/jdbc/pool/DataSource.java:66: error: self-closing element not allowed
* Unregisters the underlying connection pool mbean.<br/>
^

The problem is, that java 8 has become more strict with javadoc and per default javadoc will exits with an error if the syntax is not absolutely http conformed.

How to repeat: (be sure to have java 8 version active)
  cd modules/jdbc-pool
  mvm clean install -DskipTests

There are at minimum 2 solutions for this:
1) fix the javadoc
   --> this is my preferred option because the quality of the documentation will be better. In some cases the syntax errors would avoid some informations to be properly displayed in the final javadoc.
2) setup the javadoc plugin in maven to use a special flag to disable the syntax verification.
   --> no need to update the sources but the real problems are not solved with this solution.

More information for this problem can be found here:
http://blog.joda.org/2014/02/turning-off-doclint-in-jdk-8-javadoc.html

If nobody fixes this before and if I come to this I will fix the javadoc and upload the patch here.
Comment 1 Konstantin Kolinko 2014-09-23 11:49:27 UTC
See here on how to disable DocLint checks in maven builds:
https://jdpgrailsdev.github.io/blog/2014/04/03/maven_java8_javadoc.html
Comment 2 Pierre Viret 2014-10-07 17:41:02 UTC
Created attachment 32089 [details]
proposed patch which fixes the javadoc errors

I have fixed the javadoc errors occurring with java 8 and tested it with java 7: the javadoc can now be built with both versions without error.
Comment 3 Pierre Viret 2014-10-11 11:34:44 UTC
Who could check this patch and commit it if it's OK ?
Comment 4 Mark Thomas 2014-10-12 10:40:01 UTC
Fixed in 8.0.x for 8.0.15 onwards.
Thanks for the patch.