Bug 57068 - No error thrown when negative duration is entered in Test Action
Summary: No error thrown when negative duration is entered in Test Action
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: All All
: P2 regression (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-08 14:00 UTC by damien.aiello
Modified: 2014-10-08 20:58 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description damien.aiello 2014-10-08 14:00:16 UTC
In version 2.9, when we entered a negative duration in a test action component, an error was thrown :

2014/10/08 15:32:52 ERROR - jmeter.threads.JMeterThread: Error while processing sampler 'Action test' : java.lang.IllegalArgumentException: timeout value is negative

In version 2.10 and further, this error is not thrown anymore.


To reproduce, just put a negative value in the component, and observe the log file.
Comment 1 Philippe Mouawad 2014-10-08 20:58:32 UTC
Issue is due to switch from Thread.sleep to TimeUnit.MILLISECONDS.sleep which does not behave exactly the same (ignore negative value).
Thanks for report


Date: Wed Oct  8 20:56:20 2014
New Revision: 1630230

URL: http://svn.apache.org/r1630230
Log:
Bug 57068 - No error thrown when negative duration is entered in Test Action
Bugzilla Id: 57068

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/sampler/TestAction.java
    jmeter/trunk/xdocs/changes.xml