Bug 57107 - Patch proposal: Add DAV verbs to HTTP Sampler
Summary: Patch proposal: Add DAV verbs to HTTP Sampler
Status: RESOLVED DUPLICATE of bug 59005
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.11
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-17 15:48 UTC by Philippe Jung
Modified: 2016-02-27 09:38 UTC (History)
1 user (show)



Attachments
dav_patch.diff. Implements HTTP DAV verbs (5.52 KB, patch)
2014-10-17 15:48 UTC, Philippe Jung
Details | Diff
dav_patch_v2.diff - Implements HTTP DAV verbs - new version (5.90 KB, patch)
2014-10-17 22:47 UTC, Philippe Jung
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Jung 2014-10-17 15:48:32 UTC
Created attachment 32121 [details]
dav_patch.diff. Implements HTTP DAV verbs

The following patch adds the following verbs in HTTP Proxy Recorder / HTTP Sampler:

PROPFIND
PROPPATCH
MKCOL
COPY
MOVE
LOCK
UNLOCK

I have been able to test PROPFIND, PROPPATCH, MKCOL, COPY, MOVE mixed with DELETE, PUT & HEAD (Recording and replaying ownCloud client trafic to ownCloud server)

For the moment implementation is only in HTTPHC4Impl.java, neither in HTTPHC3Impl.java nor in HTTPJavaImpl.java

I would like to know if you are interested by this patch? In this case, I will update it with modified HTTPHC3Impl.java. Not sure HTTPJavaImpl.java is required as I have seen unimplemented methods in HTTPJavaImpl.java (PATCH as far as I can remember).
Comment 1 Philippe Jung 2014-10-17 15:49:26 UTC
Patch is based on svn trunk
Comment 2 Sebb 2014-10-17 18:19:15 UTC
Thanks!

Patch looks generally good, though I wonder if the Webdav method checking could be done in a shared utility method.

I don't think there is any need to implement the code for the HC3 or Java implementations.

However some extra documentation is needed for component_reference.xml
Comment 3 Philippe Jung 2014-10-17 22:47:13 UTC
Created attachment 32123 [details]
dav_patch_v2.diff - Implements HTTP DAV verbs - new version

- Class HttpWebdav.java extracted from HTTPHC4Impl.java to org.apache.jmeter.protocol.http.sampler
- added isWebdavMethod in HttpWebdav class
- updated other files to use isWebdavMethod
- updated xdocs/usermanual/component_reference.xml
Comment 4 Philippe Mouawad 2014-10-18 13:10:33 UTC
Date: Sat Oct 18 13:09:16 2014
New Revision: 1632785

URL: http://svn.apache.org/r1632785
Log:
Bug 57107 - Patch proposal: Add DAV verbs to HTTP Sampler
Bugzilla Id: 57107

Added:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HttpWebdav.java   (with props)
Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSampleResult.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSamplerBase.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/HTTPConstantsInterface.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 5 Philippe Mouawad 2014-10-18 13:11:17 UTC
Thanks a lot for your great contribution !
A tutorial or blog entry would be welcome :-)
Comment 6 Abhay Dubey 2016-02-15 07:34:00 UTC
SEARCH method is missing
Comment 7 Philippe Mouawad 2016-02-27 09:38:33 UTC

*** This bug has been marked as a duplicate of bug 59005 ***