Bug 57179 - Support for encrypted private keys for SSLProxyMachineCertificate directives
Summary: Support for encrypted private keys for SSLProxyMachineCertificate directives
Status: RESOLVED DUPLICATE of bug 24031
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.5-HEAD
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-03 20:43 UTC by Eric Rich
Modified: 2014-11-05 09:29 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Rich 2014-11-03 20:43:00 UTC
Currently the SSLProxyMachineCertificate do not support encrypted private keys, it would be great if an enhancement was made to allow for this.
Comment 1 Kaspar Brand 2014-11-05 09:29:47 UTC
Resolving as a duplicate, see bug 24031 comment 6 in particular.

For the sake of transparency, let me add that I'm not in support of adding such a feature - on the contrary, I think that 2.4 should be the last version with support for encrypted private keys, more background in these threads:

https://mail-archives.apache.org/mod_mbox/httpd-dev/201311.mbox/%3C52838765.8020401%40velox.ch%3E

https://mail-archives.apache.org/mod_mbox/httpd-dev/201402.mbox/%3C52F42FA2.1070607%40fifthhorseman.net%3E

*** This bug has been marked as a duplicate of bug 24031 ***