Bug 57185 - Chart "serie" should be "series"
Summary: Chart "serie" should be "series"
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: 3.11-dev
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
Depends on:
Reported: 2014-11-04 18:06 UTC by Philippe Lhoste
Modified: 2014-11-04 22:49 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Lhoste 2014-11-04 18:06:50 UTC
As a French, that' something I had difficulties to assimilate, but now I know that the word "serie" doesn't exist in English (rechecked with Merriam-Webster...), it is an invariant name "series" (not very practical for programming purpose, we have to make seriesList instead of using a plural name, etc.).

Exploring the new, beta feature of adding charts to Excel worksheets, I stumble upon a class:

 * Represents a line chart serie.
 * @author Martin Andersson
public interface LineChartSerie extends ChartSerie {

While it is in beta state, I suggest to rename them to ChartSeries and LineChartSeries.
Comment 1 Nick Burch 2014-11-04 22:49:32 UTC
Thanks, fixed in r1636755.