Bug 57188 - HTTPSampler : PUT request with file is performed with empty body when ParameterName is not empty
Summary: HTTPSampler : PUT request with file is performed with empty body when Paramet...
Status: RESOLVED DUPLICATE of bug 60015
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.11
Hardware: All All
: P2 normal (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2014-11-05 12:33 UTC by shyshkotestmail
Modified: 2018-10-27 15:02 UTC (History)
2 users (show)



Attachments
Test plan with correct and incorrect requests (14.58 KB, text/plain)
2014-11-05 12:33 UTC, shyshkotestmail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shyshkotestmail 2014-11-05 12:33:33 UTC
Created attachment 32191 [details]
Test plan with correct and incorrect requests

v.2.11
Steps: 
1. set some ParameterName for attached file in HTTP request with Method: PUT
2. Run test, verify request text
Observed:
file is not send
---------------------------------------------------------------------
PUT http://172.29.0.15/SPC/123214/batch/145?channel=Twitter

PUT data:


[no cookies]

Request Headers:
Connection: keep-alive
AuthenticationToken: RyFQpAwbvOunp25ZK3fa/nN/W/NxeF0XKzWr8XPR3JUCkXuqTgnG60hUs78pGk0itUE1o13UnXz0PjXM+gjXDCso13gU+mjV8APWukLW6KhXSX/XPdz1LUhlIM7/yCzxqW7st54uLgtuasqCw9FOzsaswO32H8VHiRMlLDlZCJ8=
Content-Type: application/x-zip-compressed
Content-Length: 0
Host: 172.29.0.15
User-Agent: Apache-HttpClient/4.2.6 (java 1.5)
-------------------------------------------------------------------

If Method is POST file is send:
--------------------------------------------------------
POST http://172.29.0.15/SPC/123214/batch/128?channel=Twitter

POST data:
--hjO9f0hp0ecbElbUGWv8EYa84Anb6r4TUm
Content-Disposition: form-data; name="dataFile"; filename="StaticData.zip"
Content-Type: application/x-zip-compressed

<actual file content, not shown here>
--hjO9f0hp0ecbElbUGWv8EYa84Anb6r4TUm--


[no cookies]

Request Headers:
Connection: keep-alive
AuthenticationToken: RyFQpAwbvOunp25ZK3fa/nN/W/NxeF0XKzWr8XPR3JUCkXuqTgnG60hUs78pGk0itUE1o13UnXz0PjXM+gjXDCso13gU+mjV8APWukLW6KhXSX/XPdz1LUhlIM7/yCzxqW7st54uLgtuasqCw9FOzsaswO32H8VHiRMlLDlZCJ8=
Content-Type: application/x-zip-compressed
Content-Length: 20090
Host: 172.29.0.15
User-Agent: Apache-HttpClient/4.2.6 (java 1.5)
-------------------------------------------------------
Comment 1 Philippe Mouawad 2018-10-27 15:02:37 UTC
Fixed in Version 5.0 as par of Bug 60015

*** This bug has been marked as a duplicate of bug 60015 ***