Bug 57206 - Different result getting in tomcat 8.0.12 and 8.0.0
Summary: Different result getting in tomcat 8.0.12 and 8.0.0
Status: RESOLVED DUPLICATE of bug 57038
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 8.0.12
Hardware: PC All
: P2 blocker (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-13 12:31 UTC by Arunava Tah
Modified: 2014-11-13 13:07 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arunava Tah 2014-11-13 12:31:51 UTC
We use CodeSource codeSource = Common.class.getProtectionDomain().getCodeSource(); this code is to get the path where jar is running. In tomacat 8.0.0 i am getting the path up to jar location like "jar:file:/C:/apache-tomcat-7.0.27/webapps/synergy/WEB-INF/lib/ISFaxAPIConnector.jar", but in 8.0.12 ,I ma getting different path location that is up to class location like "jar:file:/C:/apache-tomcat-7.0.27/webapps/synergy/WEB-INF/lib/ISFaxAPIConnector.jar!/com/ensim/escm/plugin/apiconnector/isfax/common/Common.class" .
So can you please clarify, what is reason behind this? It is creating a blocking issue to find a file using this path.
Comment 1 Konstantin Kolinko 2014-11-13 13:07:34 UTC
Test with the current 8.0.15.

*** This bug has been marked as a duplicate of bug 57038 ***