Bug 57247 - Update Jasper in Tomcat 9 to target Java 8
Update Jasper in Tomcat 9 to target Java 8
Status: RESOLVED FIXED
Product: Tomcat 9
Classification: Unclassified
Component: Jasper
unspecified
PC All
: P2 normal (vote)
: -----
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-11-24 01:04 UTC by Konstantin Kolinko
Modified: 2015-08-22 09:53 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kolinko 2014-11-24 01:04:52 UTC
The next version of JSP specification is not published yet, but my expectation is that the new set of Java EE specifications will target Java 8.

One place that we forgot to update when switching Tomcat 8 Jasper to Java 7:
\java\org\apache\jasper\resources\LocalStrings[_lang].properties

The help string there still says
\    -source <version>   Set the -source argument to the compiler (default 1.6)\n\
\    -target <version>   Set the -target argument to the compiler (default 1.6)\n\
Comment 1 Mark Thomas 2014-11-24 11:24:52 UTC
I did a global search in Tomcat 9 for "1.7" and fixed all the references I found.

I've also fixed the JspC usage message in Tomcat 8. That fix will be in 8.0.16 onwards.