Bug 57262 - Aggregate Report, Aggregate Graph and Summary Report export : headers use keys instead of labels
Summary: Aggregate Report, Aggregate Graph and Summary Report export : headers use key...
Status: RESOLVED WORKSFORME
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.12
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-26 07:05 UTC by Sandeep
Modified: 2014-12-27 14:57 UTC (History)
1 user (show)



Attachments
column headers of the aggregate report are database column names instead of table column names. (2.40 KB, text/plain)
2014-12-09 08:18 UTC, Sandeep
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sandeep 2014-11-26 07:05:21 UTC
Hi,

I was trying to export to table data of Aggregate Report and Summary Report to a file. Data gets exported is fine.Issues are:

1. Columns with Units such as Throughput are not exported to the csv file.
2. Column Headers are not exported as is in the table, instead column names used in the JMeter database is exported.

A fix for this would be well appreciated.

Thanks in advance.
Comment 1 Philippe Mouawad 2014-11-29 20:53:44 UTC
Hello,
Thanks for report although I cannot reproduce 1.
So fix will concern issue 2 on Summary Report, Aggregate Graph and Report.

Please show an example of issue 1.
Comment 2 Philippe Mouawad 2014-11-29 21:00:03 UTC
Date: Sat Nov 29 20:57:05 2014
New Revision: 1642476

URL: http://svn.apache.org/r1642476
Log:
Bug 57262 - Aggregate Report, Aggregate Graph and Summary Report export : headers use keys instead of labels
Bugzilla Id: 57262

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/StatGraphVisualizer.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/StatVisualizer.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/SummaryReport.java
    jmeter/trunk/xdocs/changes.xml
Comment 3 Sandeep 2014-12-09 08:18:43 UTC
Created attachment 32272 [details]
column headers of the aggregate report are database column names instead of table column names.
Comment 4 Sandeep 2014-12-09 08:22:09 UTC
Issue persists, though, Save Table headers option is checked in while exporting the .CSV file, database column headers are exported and not the table column headers. 

The above issue is observed in Summary Report and similar table data export reports.
Comment 5 UbikLoadPack support 2014-12-22 20:52:35 UTC
Are you sure you are using Nightly build ?
We cannot reproduce issue.
What language are you using ?

Thanks