Bug 57398 - AH01075: Error dispatching request to : (passing brigade to output filters)
Summary: AH01075: Error dispatching request to : (passing brigade to output filters)
Status: RESOLVED DUPLICATE of bug 49671
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy_fcgi (show other bugs)
Version: 2.4.10
Hardware: Other Linux
: P2 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-26 22:04 UTC by Erico
Modified: 2016-07-28 11:06 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erico 2014-12-26 22:04:03 UTC
With the main error message, I keep getting the "Bogus version" error messages too.

Messages are sent using a custom ErrorLogFormat + syslog. I only get these messages on my busiest websites.

Dec 26 21:14:34 test apache2[3422]: [proxy_fcgi:error] AH01068: Got bogus version 109
Dec 26 21:14:34 test apache2[3422]: [proxy_fcgi:error] AH01075: Error dispatching request to : (passing brigade to output filters)
Dec 26 21:15:44 test apache2[3422]: [proxy_fcgi:error] AH01068: Got bogus version 109
Dec 26 21:15:44 test apache2[3422]: [proxy_fcgi:error] AH01075: Error dispatching request to : (passing brigade to output filters)
Dec 26 21:22:44 test apache2[3422]: [proxy_fcgi:error] AH01068: Got bogus version 10
Dec 26 21:22:44 test apache2[3422]: [proxy_fcgi:error] AH01075: Error dispatching request to : (passing brigade to output filters)
Dec 26 21:28:49 test apache2[3422]: [proxy_fcgi:error] AH01068: Got bogus version 199
Dec 26 21:28:49 test apache2[3422]: [proxy_fcgi:error] AH01075: Error dispatching request to : (passing brigade to output filters)
Dec 26 21:38:20 test apache2[3422]: [proxy_fcgi:error] AH01068: Got bogus version 252
Dec 26 21:38:20 test apache2[3422]: [proxy_fcgi:error] AH01075: Error dispatching request to : (passing brigade to output filters)

-----

Apache 2.4.10
Ubuntu 14.04
PHP5-FPM: 5.5.9

-----

<IfModule mod_proxy.c>
  
  ProxyTimeout 900
  
  <Proxy fcgi://127.0.0.1:9000>
    ProxySet connectiontimeout=5 timeout=900 retry=3
  </Proxy>

</IfModule>

--

<VirtualHost *:443>

  ...

  ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/test/$1
  DirectoryIndex /index.php

</Virtualhost>
Comment 1 Luca Toscano 2016-07-08 08:35:59 UTC
This bug is almost for sure related to:

https://bz.apache.org/bugzilla/show_bug.cgi?id=49671

I managed to reproduce it simply forcing the FCGI backend (in my case HHVM) to serve a huge file and stopping a HTTP request for it before completion. 

The fix is https://svn.apache.org/r1682544, that is contained in 2.4.16

*** This bug has been marked as a duplicate of bug 49671 ***
Comment 2 Luca Toscano 2016-07-08 11:02:20 UTC
Sorry my previous entry was not correct, only two trivial patches are needed to remove these logs:

http://svn.apache.org/r1642855
http://svn.apache.org/r1726019

These should also remove occurrences of "Got bogus rid X, expected 1"
Comment 3 Luca Toscano 2016-07-28 11:06:31 UTC
Last reference! http://svn.apache.org/r1752347

This one is a specific use case, namely 304s logged as 503s.