Bug 57444 - AbstractHttp11JsseProtocol expects KeyStore to be in a File
Summary: AbstractHttp11JsseProtocol expects KeyStore to be in a File
Status: RESOLVED DUPLICATE of bug 56777
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 8.0.x-trunk
Hardware: PC All
: P2 major (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-14 18:58 UTC by Axel Fontaine
Modified: 2015-01-14 20:15 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Fontaine 2015-01-14 18:58:28 UTC
This is highly problematic for the new executable Jars types of deployments like Spring Boot, as it effectively requires you to extract the KeyStore out of the Jar file, onto disk, to be able to pass it in.

This API should really be stream-based instead.
Comment 1 Mark Thomas 2015-01-14 20:15:28 UTC

*** This bug has been marked as a duplicate of bug 56777 ***