Bug 57555 - Cannot use JMeter 2.12 as a maven dependency
Summary: Cannot use JMeter 2.12 as a maven dependency
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.12
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 57649 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-10 08:48 UTC by pascal.schumacher
Modified: 2015-02-28 16:39 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pascal.schumacher 2015-02-10 08:48:37 UTC
I'm unable to use JMeter 2.12 as a maven dependency, e.g. of the jmeter-maven-plugin.

This seems to be caused by the update of excalibur-datasource to 2.1 in JMeter 2.12 (JMeter 2.10 and 2.11 worked).

Excalibur-datasource 2.1 has a dependency on d-haven-managed-pool:d-haven-managed-pool:1.0,but this dependency can not be found in maven central (or any other maven repo I'm aware of).

I guess the dependency should really be d-haven-mpool:managed-pool:1.0.

Managed-pool in turn has a dependency on event:event:1.0 which is also not in a maven repo. This should be d-haven-event:d-haven-event:1.0.3 or d-haven-event:event:1.0.1.

I was able to get it to work by excluding d-haven-managed-pool:d-haven-managed-pool and event:event and adding d-haven-mpool:managed-pool manually:

<dependency>
    <groupId>org.apache.jmeter</groupId>
    <artifactId>ApacheJMeter</artifactId>
    <version>2.12</version>
    <exclusions>
        <exclusion>
            <groupId>d-haven-managed-pool</groupId>
            <artifactId>d-haven-managed-pool</artifactId>
        </exclusion>
    </exclusions>
</dependency>
<dependency>
    <groupId>d-haven-mpool</groupId>
    <artifactId>managed-pool</artifactId>
    <version>1.0</version>
    <exclusions>
        <exclusion>
            <groupId>event</groupId>
            <artifactId>event</artifactId>
        </exclusion>
    </exclusions>
</dependency>

Obviously this is not caused by JMeter, but by excalibur-datasource. But as excalibur has been retired a long time ago it would  be great if this could be fixed in JMeter, e.g. by using the workaround described above.
Comment 1 Sebb 2015-02-10 23:20:55 UTC
Looks like we cannot revert to the previous version because of Bug 55977.
Comment 2 pascal.schumacher 2015-02-12 17:04:31 UTC
I did some further investigation and noticed that the non-existing "d-haven-managed-pool:d-haven-managed-pool:1.0" dependency is a transitive dependency of excalibur-fortress. The JMeter distribution does not include excalibur-fortress. This means the bug can be fixed by excluding the excalibur-fortress dependencies of excalibur-datasource in /res/maven/ApacheJMeter_parent.pom

Just replace:

<dependency>
        <groupId>excalibur-datasource</groupId>
        <artifactId>excalibur-datasource</artifactId>
        <version>${excalibur-datasource.version}</version>
</dependency>

with:

<dependency>
        <groupId>excalibur-datasource</groupId>
        <artifactId>excalibur-datasource</artifactId>
        <version>${excalibur-datasource.version}</version>
        <exclusions>
            <exclusion>
                <groupId>excalibur-fortress</groupId>
                <artifactId>excalibur-fortress-container-api</artifactId>
            </exclusion>
            <exclusion>
                <groupId>excalibur-fortress</groupId>
                <artifactId>excalibur-fortress-meta</artifactId>
            </exclusion>
        </exclusions>
</dependency>
Comment 3 Philippe Mouawad 2015-02-12 20:23:02 UTC
Date: Thu Feb 12 20:17:50 2015
New Revision: 1659390

URL: http://svn.apache.org/r1659390
Log:
Bug 57555 - Cannot use JMeter 2.12 as a maven dependency
Bugzilla Id: 57555

Modified:
    jmeter/trunk/res/maven/ApacheJMeter_parent.pom
    jmeter/trunk/xdocs/changes.xml
Comment 4 Philippe Mouawad 2015-02-12 20:23:23 UTC
Thanks for your report, analysis and fix.
Comment 5 Rainer Jung 2015-02-28 16:39:44 UTC
*** Bug 57649 has been marked as a duplicate of this bug. ***