Bug 57716 - Log viewer undo memory leak
Summary: Log viewer undo memory leak
Status: RESOLVED DUPLICATE of bug 57440
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.12
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-16 16:51 UTC by Alejandro Vazquez
Modified: 2015-03-16 19:57 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Vazquez 2015-03-16 16:51:51 UTC
A test plan that constantly produces ERROR log entries builds up javax.swing.text.GapContent$UndoPosRef instances for every ERROR log entry added to the Log Viewer component. The instances' memory is not released until the test plan execution is stopped.

To reproduce the bug:

  * Create an empty test plan

  * Add a new thread group

  * Add a BeanShell sampler with the following line of code:

        SampleResult.setEndTime(System.currentTimeMillis());

  * Set the thread group to execute forever.

  * Optionally add a Constant Timer to avoid leaking memory too fast.

Workaround:

  * Modify user.preferences to reduce ERROR log entries being appended to the Log Viewer.
Comment 1 Philippe Mouawad 2015-03-16 19:57:39 UTC
Hello,
Thanks for report.
This bug has been fixed in release 2.13 which is available since yesterday.
Initial bug was 57440.
Regards

*** This bug has been marked as a duplicate of bug 57440 ***