Bug 57731 - TESTSTART.MS has always the value of the first Test started in Server mode in NON GUI Distributed testing
Summary: TESTSTART.MS has always the value of the first Test started in Server mode in...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.12
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-20 10:37 UTC by ateles.belzebuth.hybridus+apache
Modified: 2015-04-18 12:02 UTC (History)
1 user (show)



Attachments
test plan to reproduce error (5.02 KB, application/xml)
2015-03-23 15:48 UTC, ateles.belzebuth.hybridus+apache
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ateles.belzebuth.hybridus+apache 2015-03-20 10:37:06 UTC
Hi,

when a test plan is run on a remote JMeter server, the variable TESTSTART.MS is set on the first run, only. Upon further test runs, even with different test plans, it keeps it value and is not updated to the start time of the current run.
This behavior doesn't occur when running the test on the local JMeter instance.

Best regards, @
Comment 1 Sebb 2015-03-20 16:34:55 UTC
Just checked the GUI.

It updates TESTSTART.MS (property and variable) for each run.
Comment 2 ateles.belzebuth.hybridus+apache 2015-03-22 01:20:55 UTC
I run the server under Linux (Debian stable i386) with openjdk-jre, started via the bin/jmeter-server shell script.
The client was run under Windows 7 with Oracle Java 7 started via »bin/jmeter.bat -Jremote_servers=linux-server«
The test plan passes ${TESTSTART.MS} as GET parameter in a HTTP sampler to the tested server. A »View Results Tree« listener shows this parameter as constant over the test runs, if the test is run on the remote JMeter. (Also a Bean shell script sees the variable as constant.)
I couldn't verify this behavior with JMeter 2.13, because remote testing failed completely. (But I am not sure, if this is due to a bug or configuration problem.)
Comment 3 ateles.belzebuth.hybridus+apache 2015-03-23 15:48:21 UTC
Created attachment 32593 [details]
test plan to reproduce error
Comment 4 ateles.belzebuth.hybridus+apache 2015-03-23 15:53:49 UTC
I did some additional tests. JMeter-2.13 is also affected by this problem.
Despite by earlier comment, I used Java 6 on all platforms (Oracle Java 6 on Windows 7; java-6-openjdk on Debian stable Linux).
To reporduce the error:
- start apache-jmeter-2.13/bin/jmeter-server
- start apache-jmeter-2.13/bin/jmeter -Jremote_hosts=localhost
- open attached test plan
- click in the menu bar on Run/Remote Start/localhost
- do a second remote run
- open the View Resukts Tree to inspect the requests the HTTP Sampler made
On both remote runs TESTSTART.MS had the same value.
Comment 5 Philippe Mouawad 2015-04-16 20:48:37 UTC
Issue only affects NON-GUI mode due to the fact that 
JMeterContextService#endTest which resets testStart attribute is only called in GUI mode.
So I confirm bug.
Comment 6 Philippe Mouawad 2015-04-18 12:02:37 UTC
Date: Sat Apr 18 12:02:17 2015
New Revision: 1674486

URL: http://svn.apache.org/r1674486
Log:
Bug 57731 - TESTSTART.MS has always the value of the first Test started in Server mode in NON GUI Distributed testing
Bugzilla Id: 57731

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/engine/StandardJMeterEngine.java
    jmeter/trunk/xdocs/changes.xml