Bug 57734 - Maven transient dependencies are incorrect for 2.13
Summary: Maven transient dependencies are incorrect for 2.13
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 57748 57972 58250 58251 58447 58448 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-22 10:22 UTC by Mark Collin
Modified: 2015-10-03 20:39 UTC (History)
5 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Collin 2015-03-22 10:22:38 UTC
The transient dependencies are incorrect for version 2.13.  This is not a duplicate of 57555 as the dependency errors are different.

It looks like the JMeter POMS are expecting 

<dependency>
    <groupId>commons-math3</groupId>
    <artifactId>commons-math3</artifactId>
    <version>3.4.1</version>
</dependency>
<dependency>
    <groupId>commons-pool2</groupId>
    <artifactId>commons-pool2</artifactId>
    <version>2.3</version>
</dependency>

When they should be expecting

<dependency>
    <groupId>org.apache.commons</groupId>
    <artifactId>commons-math3</artifactId>
    <version>3.4.1</version>
</dependency>
<dependency>
    <groupId>org.apache.commons</groupId>
    <artifactId>commons-pool2</artifactId>
    <version>2.3</version>
</dependency>

Can a test be added to check the transient dependencies as part of the build, this should be very easy to pick up.
Comment 1 Philippe Mouawad 2015-03-22 14:05:49 UTC
Date: Sun Mar 22 13:34:17 2015
New Revision: 1668368

URL: http://svn.apache.org/r1668368
Log:
Bug 57734 - Maven transient dependencies are incorrect for 2.13
Bugzilla Id: 57734

Modified:
    jmeter/trunk/res/maven/ApacheJMeter_parent.pom
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2015-03-22 14:08:15 UTC
Created 57735 to handle check.
Comment 3 Rainer Jung 2015-03-24 10:55:28 UTC
*** Bug 57748 has been marked as a duplicate of this bug. ***
Comment 4 Sebb 2015-03-26 02:28:34 UTC
As pointed out on the dev list, there needs to be a test for this so it does not happen again.

Re-opening so this is not overlooked.
Comment 5 Sebb 2015-03-26 02:32:03 UTC
I see this was raised as bug 57735.
Comment 6 Philippe Mouawad 2015-05-29 21:22:18 UTC
*** Bug 57972 has been marked as a duplicate of this bug. ***
Comment 7 Sebb 2015-08-17 11:48:41 UTC
*** Bug 58251 has been marked as a duplicate of this bug. ***
Comment 8 Sebb 2015-08-17 11:48:51 UTC
*** Bug 58250 has been marked as a duplicate of this bug. ***
Comment 9 Philippe Mouawad 2015-09-24 06:56:25 UTC
*** Bug 58447 has been marked as a duplicate of this bug. ***
Comment 10 Philippe Mouawad 2015-10-03 20:39:53 UTC
*** Bug 58448 has been marked as a duplicate of this bug. ***