Bug 57748 - The dependency on math3 and pool2 are wrong in Jmeter pom
Summary: The dependency on math3 and pool2 are wrong in Jmeter pom
Status: RESOLVED DUPLICATE of bug 57734
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 blocker (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-24 09:31 UTC by Emmanuel L
Modified: 2015-03-24 12:56 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emmanuel L 2015-03-24 09:31:52 UTC
When we use a dependency on JMeter core 2.13, it pulls many transitive depencencies taken from jmeter core pom. The ones on math3 and pool2 is wrong :

      <dependency>
        <groupId>commons-math3</groupId>
        <artifactId>commons-math3</artifactId>
        <version>${commons-math3.version}</version>
      </dependency>

      <dependency>
        <groupId>commons-pool2</groupId>
        <artifactId>commons-pool2</artifactId>
        <version>${commons-pool2.version}</version>
      </dependency>

should be

      <dependency>
        <groupId>org.apache.commons</groupId>
        <artifactId>commons-math3</artifactId>
        <version>${commons-math3.version}</version>
      </dependency>

      <dependency>
        <groupId>org.apache.commons</groupId>
        <artifactId>commons-pool2</artifactId>
        <version>${commons-pool2.version}</version>
      </dependency>


That currently breaks our apache directory fortress core build if we try to switch to 2.13 (another breackage due to another missing dep with 2.12, we have to use 2.11)
Comment 1 Rainer Jung 2015-03-24 10:55:28 UTC

*** This bug has been marked as a duplicate of bug 57734 ***
Comment 2 Philippe Mouawad 2015-03-24 12:41:31 UTC
Hi Emmanuel,
Do you need us to release a 2.13.1 including the fix or can it wait ?
Thanks
Regards
Comment 3 Emmanuel L 2015-03-24 12:56:16 UTC
Hi Philippe,

no, that's ok, I can live with 2.11 atm. Thanks for asking !