Bug 57821 - Command-line option "-X --remoteexit" doesn't work since 2.13 (regression related to Bug 57500)
Summary: Command-line option "-X --remoteexit" doesn't work since 2.13 (regression rel...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 regression (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-16 14:04 UTC by bruno.michaud
Modified: 2015-04-16 20:00 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bruno.michaud 2015-04-16 14:04:57 UTC
The command-line option to shutdown a remote server after the test run has stopped working in version 2.13 r1665067. (Was working fine in version 2.12 r1636949)
I tried it on Windows and Linux servers, invoking from Windows or Linux, and none of the combinations work.
However the shutdown from the GUI still functions properly. Only the command-line fails to shutdown the remote server.

Example command and output:
C:\Users\771609\Documents\JMeter>c:\DATA\771609\JMeter13\bin\jmeter-t.cmd Dummy.jmx -Rmtl-apm01d -n -X
Creating summariser <summary>
Created the tree successfully using Dummy.jmx
Configuring remote engine: mtl-apm01d
Starting remote engines
Starting the test @ Thu Apr 16 09:50:46 EDT 2015 (1429192246376)
Remote engines have been started
summary =      1 in   0.1s =   12.8/s Avg:     5 Min:     5 Max:     5 Err:     0 (0.00%)
Tidying up remote @ Thu Apr 16 09:50:46 EDT 2015 (1429192246876)
Exitting remote servers
... end of run

But the server on the remote machine doesn't shutdown, just keeps running with no error message, still usable. This behavior is the same no matter if the "remote" server is on the localhost, or on a true separate machine.
Comment 1 Philippe Mouawad 2015-04-16 20:00:31 UTC
Date: Thu Apr 16 19:59:36 2015
New Revision: 1674142

URL: http://svn.apache.org/r1674142
Log:
Bug 57821 - Command-line option "-X --remoteexit" doesn't work since 2.13 (regression related to Bug 57500)
Bugzilla Id: 57821

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/JMeter.java
    jmeter/trunk/src/core/org/apache/jmeter/engine/DistributedRunner.java
    jmeter/trunk/xdocs/changes.xml