Bug 58011 - Tomcat 7 crasches intermittently with NIO and HTTPS
Summary: Tomcat 7 crasches intermittently with NIO and HTTPS
Status: RESOLVED DUPLICATE of bug 57265
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Connectors (show other bugs)
Version: 7.0.61
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-08 15:17 UTC by Carl Zetterberg
Modified: 2015-06-09 09:04 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carl Zetterberg 2015-06-08 15:17:04 UTC
Running Tomcat 7.0.61 as service with mostly HTTPS - it will terminate after a few days or sometimes hours.

We use java 8_45 on Windows 2008 server.

From server.xml:

<Executor name="tomcatThreadPool" namePrefix="catalina-exec-"
        maxThreads="150" minSpareThreads="4"/>

<Connector port="80" 
	executor="tomcatThreadPool" 
        redirectPort="443" />


<Connector port="443" 
   protocol="org.apache.coyote.http11.Http11NioProtocol"
			executor="tomcatThreadPool" 
			scheme="https" 
			secure="true" 
			SSLEnabled="true"
			sslProtocol="TLS"
			/>

Error message:

Fault:500 in page: /corp/report/CSEVERE: 
java.lang.IllegalArgumentException: You can only write using the application write buffer provided by the handler.
	at org.apache.tomcat.util.net.SecureNioChannel.write(SecureNioChannel.java:482)
	at sun.nio.ch.FileChannelImpl.transferToArbitraryChannel(Unknown Source)
	at sun.nio.ch.FileChannelImpl.transferTo(Unknown Source)
	at org.apache.tomcat.util.net.NioEndpoint$Poller.processSendfile(NioEndpoint.java:1352)
	at org.apache.tomcat.util.net.NioEndpoint$Poller.processKey(NioEndpoint.java:1271)
	at org.apache.tomcat.util.net.NioEndpoint$Poller.run(NioEndpoint.java:1231)
	at java.lang.Thread.run(Unknown Source)

jun 08, 2015 1:18:20 EM org.apache.tomcat.util.net.NioEndpoint$Poller processSendfile
SEVERE: 
java.lang.IllegalArgumentException: You can only write using the application write buffer provided by the handler.
	at org.apache.tomcat.util.net.SecureNioChannel.write(SecureNioChannel.java:482)
	at sun.nio.ch.FileChannelImpl.transferToArbitraryChannel(Unknown Source)
	at sun.nio.ch.FileChannelImpl.transferTo(Unknown Source)
	at org.apache.tomcat.util.net.NioEndpoint$Poller.processSendfile(NioEndpoint.java:1352)
	at org.apache.tomcat.util.net.NioEndpoint$Poller.processKey(NioEndpoint.java:1271)
	at org.apache.tomcat.util.net.NioEndpoint$Poller.run(NioEndpoint.java:1231)
	at java.lang.Thread.run(Unknown Source)
Comment 1 Mark Thomas 2015-06-09 09:04:31 UTC

*** This bug has been marked as a duplicate of bug 57265 ***