Bug 58080 - Raising the IllegalArgujent Exception at 480 row
Summary: Raising the IllegalArgujent Exception at 480 row
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: unspecified
Hardware: PC All
: P2 critical (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-29 07:32 UTC by Sharanappa.M.C
Modified: 2015-06-29 13:34 UTC (History)
0 users



Attachments
Code which is causing exception (31.78 KB, text/plain)
2015-06-29 07:32 UTC, Sharanappa.M.C
Details
Attached excel is the exact fille should generate with my code (127.50 KB, application/x-ole-storage)
2015-06-29 10:12 UTC, Sharanappa.M.C
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sharanappa.M.C 2015-06-29 07:32:15 UTC
Created attachment 32860 [details]
Code which is causing exception

In function addTeamUserDetails(),I am geting the IllegalArguement exception at only 480 count value. 

For other than 480 it is working fine.

I am using poi-3.2-Final.jar
Comment 1 Dominik Stadler 2015-06-29 09:57:05 UTC
Can you try with the latest release, we already have 3.12, so 3.2 is quite outdated and it may be fixed in newer versions already. Please note that we usually do not release fixes for older versions any more anyway.
Comment 2 Sharanappa.M.C 2015-06-29 10:12:07 UTC
Created attachment 32861 [details]
Attached excel is the exact fille should generate with my code

My code is working for all hotels and users.

But once the count value is 480 am getting the exception.

I Highlightted the data with yellow color, where the exception is raised and skipped the writing the data bcoz of exception.

I want to know what is the reason.
Comment 3 Sharanappa.M.C 2015-06-29 10:35:45 UTC
Iam getting the below exception:


java.lang.IllegalArgumentException: Specified rowIndex 480 is outside the allowable range (0..480)
	at org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate.removeAllCellsValuesForRow(ValueRecordsAggregate.java:111)
Comment 4 Dominik Stadler 2015-06-29 13:34:50 UTC
As far as I see in the changelogs this was fixed 7 and a half years ago with the following commit, I can only suggest to update to the latest version and try again. There is likely no other fix/workaround possible.

r722206 | josh | 2008-12-01 20:59:46 MEZ

Fix for bug 46312 - ValueRecordsAggregate should handle removal of new empty row
----------------------------------------------------------------------------

If you still see an error with latest POI version 3.12, please reopen this bug with a more self-contained unit test, the code that you provided is very hard to understand/reproduce for somebody not involved in your specific project, better to have a small test-program or unit test which shows the problem without any of you Servlet/... code.