Bug 58114 - Issue on while Adding Components under Threadgroup using mouse scrolling except Listeners
Summary: Issue on while Adding Components under Threadgroup using mouse scrolling exce...
Status: RESOLVED DUPLICATE of bug 56150
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-08 09:32 UTC by Ram
Modified: 2016-07-31 18:53 UTC (History)
1 user (show)



Attachments
in JMETER CMD console window. (76.43 KB, image/png)
2015-07-08 09:32 UTC, Ram
Details
while scrolling jmeter menus are vanishing/hanging (72.25 KB, image/png)
2015-07-08 10:47 UTC, Ram
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ram 2015-07-08 09:32:23 UTC
Created attachment 32890 [details]
in JMETER CMD console window.

While Adding Components under Threadgroup using mouse scroll it will simply hangs and in jmeter CMD windows displaying exception like :
Uncaught Exception java.lang.ArrayIndexOutOfBoundsException: -1. See log file for details.
Uncaught Exception java.lang.ArrayIndexOutOfBoundsException: -1. See log file for details.
Uncaught Exception java.lang.ArrayIndexOutOfBoundsException: -16. See log file for details.
Uncaught Exception java.lang.ArrayIndexOutOfBoundsException: -16. See log file for details.
Uncaught Exception java.lang.ArrayIndexOutOfBoundsException: -19. See log file for details.
Uncaught Exception java.lang.ArrayIndexOutOfBoundsException: -19. See log file for details.
Comment 1 Sebb 2015-07-08 10:28:11 UTC
What are the log file messages?

What OS are you using?

Which version of Java?
Comment 2 Ram 2015-07-08 10:35:20 UTC
OS: Windows 8.1 enterprise.

java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)
Comment 3 Ram 2015-07-08 10:44:21 UTC
The Log file Message are,

2015/07/08 16:11:40 ERROR - jmeter.JMeter: Uncaught exception:  java.lang.ArrayIndexOutOfBoundsException: -12
	at org.apache.jorphan.gui.MenuScroller.refreshMenu(MenuScroller.java:552)
	at org.apache.jorphan.gui.MenuScroller.access$300(MenuScroller.java:55)
	at org.apache.jorphan.gui.MenuScroller$MouseScrollListener.mouseWheelMoved(MenuScroller.java:578)
	at java.awt.Component.processMouseWheelEvent(Component.java:6593)
	at java.awt.Component.processEvent(Component.java:6277)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventToSelf(Container.java:2311)
	at java.awt.Component.dispatchMouseWheelToAncestor(Component.java:5014)
	at java.awt.Component.dispatchEventImpl(Component.java:4745)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4521)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:702)
	at java.awt.EventQueue$4.run(EventQueue.java:700)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Comment 4 Ram 2015-07-08 10:47:36 UTC
Created attachment 32891 [details]
while scrolling jmeter menus are vanishing/hanging
Comment 5 Philippe Mouawad 2016-07-31 18:53:51 UTC

*** This bug has been marked as a duplicate of bug 56150 ***