Bug 58160 - JMS Publisher : reload file content if file name changes
Summary: JMS Publisher : reload file content if file name changes
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-21 12:03 UTC by maxime.chassagneux
Modified: 2015-11-11 13:51 UTC (History)
2 users (show)



Attachments
Patch file to disable cache when filename change (478 bytes, text/plain)
2015-07-21 12:03 UTC, maxime.chassagneux
Details
Patch file to disable cache when filename change (706 bytes, patch)
2015-07-23 14:44 UTC, maxime.chassagneux
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description maxime.chassagneux 2015-07-21 12:03:21 UTC
Created attachment 32918 [details]
Patch file to disable cache when filename change

I've made this little hack (see attachment) on the JMS Publisher component to disabled the cache when the file name change ( by example when you variabilize the field )

Could you look at it and add it if possible. May be on other component where cache is use.
Comment 1 UbikLoadPack support 2015-07-21 12:14:44 UTC
Hello,
Your patch cannot be used as we don't know to which class it applies.

How did you create it ?

You should first read this:
http://wiki.apache.org/jmeter/JMeterDevelopment
http://wiki.apache.org/jmeter/JMeterEclipse
http://wiki.apache.org/jmeter/CommittingChanges (This link gives high level  steps) 

Then to submit a patch, in Eclipse :
Right click on JMeter projet > Team > create patch and select the files you want to include in patch.

Regards
Comment 2 maxime.chassagneux 2015-07-21 12:24:19 UTC
(In reply to UbikLoadPack support from comment #1)
> Hello,
> Your patch cannot be used as we don't know to which class it applies.
> 
> How did you create it ?
> 
> You should first read this:
> http://wiki.apache.org/jmeter/JMeterDevelopment
> http://wiki.apache.org/jmeter/JMeterEclipse
> http://wiki.apache.org/jmeter/CommittingChanges (This link gives high level 
> steps) 
> 
> Then to submit a patch, in Eclipse :
> Right click on JMeter projet > Team > create patch and select the files you
> want to include in patch.
> 
> Regards

Ho sry, I use WinMerge to do it ... 

I will look an other way to generate it...
Comment 3 maxime.chassagneux 2015-07-21 12:25:34 UTC
The patch was made on "src\protocol\jms\org\apache\jmeter\protocol\jms\sampler\PublisherSampler.java" file.
Comment 4 maxime.chassagneux 2015-07-23 14:44:38 UTC
Created attachment 32932 [details]
Patch file to disable cache when filename change

new version of the patch
Comment 5 Zafiu Andrei 2015-11-11 13:09:01 UTC
Any news on applying this patch? I can confirm it and it applies since version 2.7 of apache jmeter.
Comment 6 Philippe Mouawad 2015-11-11 13:50:04 UTC
Author: pmouawad
Date: Wed Nov 11 13:49:31 2015
New Revision: 1713842

URL: http://svn.apache.org/viewvc?rev=1713842&view=rev
Log:
Bug 58160 - JMS Publisher : reload file content if file name changes
Bugzilla Id: 58160

Modified:
    jmeter/trunk/src/protocol/jms/org/apache/jmeter/protocol/jms/sampler/PublisherSampler.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 7 Philippe Mouawad 2015-11-11 13:51:18 UTC
Thanks for contribution, it was partly rewritten.

It would be nice to have feedback on nightly build (available tomorrow) to see if everything works fine.
http://jmeter.apache.org/nightly.html
Download the _bin and _lib files
Unpack the archives into the same directory structure
The other archives are not needed to run JMeter. 
Thanks