Bug 58218 - Blocked trying to get lock: org/apache/log4j/spi/RootLogger
Summary: Blocked trying to get lock: org/apache/log4j/spi/RootLogger
Status: RESOLVED DUPLICATE of bug 57714
Alias: None
Product: Log4j - Now in Jira
Classification: Unclassified
Component: Other (show other bugs)
Version: unspecified
Hardware: Other Linux
: P1 blocker
Target Milestone: ---
Assignee: log4j-dev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-06 12:17 UTC by Aakash
Modified: 2015-08-10 14:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aakash 2015-08-06 12:17:46 UTC
I have found the following thread in the thread dumps which is causing delay in application.Could you please help me to resolve this issue.


###<Jul 21, 2015 9:23:58 AM IST> <Info> <Server> <aukpczbr.dc-dublin.de> <aukpczbr_p2> <[ACTIVE] ExecuteThread: '13' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1437467038573> <BEA-002634> <The server "pci_p2_ad_admin" disconnected from this server.> 
####<Jul 21, 2015 9:23:58 AM IST> <Error> <WebLogicServer> <aukpczbr.dc-dublin.de> <aukpczbr_p2> <[STANDBY] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1437467038600> <BEA-000337> <[STUCK] ExecuteThread: '16' for queue: 'weblogic.kernel.Default (self-tuning)' has been busy for "652" seconds working on the request "weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl@58887aee", which is more than the configured time (StuckThreadMaxTime) of "600" seconds. Stack trace:
Thread-3471 "[STUCK] ExecuteThread: '16' for queue: 'weblogic.kernel.Default (self-tuning)'" <alive, suspended, blocked, priority=1, DAEMON> {
    -- Blocked trying to get lock: org.apache.log4j.spi.RootLogger@21cb1369[not locked]
    org.apache.log4j.Category.callAppenders(Category.java:204)
    org.apache.log4j.Category.forcedLog(Category.java:391)
    org.apache.log4j.Category.log(Category.java:856)
    org.slf4j.impl.Log4jLoggerAdapter.error(Log4jLoggerAdapter.java:541)
    com.vodafone.pciadaptor.core.emis.HttpConnectionProbe.onRun(HttpConnectionProbe.java:105)
    com.vodafone.pciadaptor.core.scheduling.AbstractScheduledTask.run(AbstractScheduledTask.java:42)
    org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:51)
    java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
    java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
    java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
    org.springframework.scheduling.commonj.TimerManagerTaskScheduler$TimerScheduledFuture.timerExpired(TimerManagerTaskScheduler.java:112)
    org.springframework.scheduling.commonj.TimerManagerTaskScheduler$ReschedulingTimerListener.timerExpired(TimerManagerTaskScheduler.java:165)
    weblogic.timers.internal.commonj.ListenerWrap.timerExpired(ListenerWrap.java:37)
    weblogic.timers.internal.TimerImpl.run(TimerImpl.java:273)
    weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
    weblogic.work.ExecuteThread.execute(ExecuteThread.java:207)
    weblogic.work.ExecuteThread.run(ExecuteThread.java:176)
}

>
Comment 1 Aakash 2015-08-10 13:41:52 UTC
Can someone help me for the below defect please.
Comment 2 Ralph Goers 2015-08-10 14:06:05 UTC
This appears to be a duplicate of 57714. Please see that issue for updates.

Also, please see https://blogs.apache.org/foundation/entry/apache_logging_services_project_announces

*** This bug has been marked as a duplicate of bug 57714 ***