Bug 58329 - Response Time Graph and Aggregate Graph : Save graph to file does not take into account the settings changed since last click on Graph
Summary: Response Time Graph and Aggregate Graph : Save graph to file does not take in...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2015-09-04 17:01 UTC by Danilo Mendes
Modified: 2016-03-23 21:47 UTC (History)
2 users (show)



Attachments
Patch for bug 58329 (851 bytes, patch)
2016-03-23 21:29 UTC, David Coppens
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Danilo Mendes 2015-09-04 17:01:39 UTC
Hi,

There's a minor bug when saving a graph in JMeter GUI in Listener Aggregate Graph.
When you save the graph to file, the image that is saved does not contains the settings you specified unless you change to Tab "Graph".

Possible solution: Invalidate image before saving the image.

To reproduce do the following steps:
(I'll consider that you already have a set of data to build the graphic)
  1. Open Aggregate Graph component
  2. Open "Graph" tab (The graph should be displayed with the default settings)
  3. Now go back to "Settings" tab.
  4. Change a bunch of visual settings like font size, title, etc... Go nuts..
DO NOT change back to "Graph" tab.
  5. Save the graph to file with button "Save", and save it to disk with any name.
  6. Open the png and there you go, the new settings inserted are not there.

Any further question do not hesitate to ask.

Best regards,
Danilo Mendes
Comment 1 David Coppens 2016-03-23 21:29:13 UTC
Created attachment 33698 [details]
Patch for bug 58329
Comment 2 David Coppens 2016-03-23 21:31:48 UTC
Attached patch for this bug. 

Updated getPrintableComponent() method inherited from SaveGraphics component to always draw the graph before providing the graph to be saved.
Comment 3 Philippe Mouawad 2016-03-23 21:47:47 UTC
Date: Wed Mar 23 21:47:27 2016
New Revision: 1736381

URL: http://svn.apache.org/viewvc?rev=1736381&view=rev
Log:
Bug 58329 - Response Time Graph and Aggregate Graph : Save graph to file does not take into account the settings changed since last click on Graph
Bugzilla Id: 58329

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/RespTimeGraphVisualizer.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/StatGraphVisualizer.java
    jmeter/trunk/xdocs/changes.xml