Bug 58400 - Data race on field org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.cometNotify
Summary: Data race on field org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.comet...
Status: RESOLVED DUPLICATE of bug 58396
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Util (show other bugs)
Version: 8.0.x-trunk
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-12 17:27 UTC by Yilong Li
Modified: 2015-09-18 09:00 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yilong Li 2015-09-12 17:27:31 UTC
Reported by RV-Predict (a dynamic race detector) when running the test suite:
Data race on field org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.cometNotify: {{{
    Concurrent write in thread T30 (locks held: {})
 ---->  at org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.setCometNotify(NioEndpoint.java:1359)
        at org.apache.tomcat.util.net.NioEndpoint.processSocket(NioEndpoint.java:620)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.cancelledKey(NioEndpoint.java:965)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.processKey(NioEndpoint.java:1117)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.timeout(NioEndpoint.java:1316)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.run(NioEndpoint.java:1056)
    T30 is created by T1
        at org.apache.tomcat.util.net.NioEndpoint.startInternal(NioEndpoint.java:426)

    Concurrent write in thread T37 (locks held: {Monitor@3d2263f5})
 ---->  at org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.setCometNotify(NioEndpoint.java:1359)
        at org.apache.tomcat.util.net.NioEndpoint.processSocket(NioEndpoint.java:620)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.add(NioEndpoint.java:903)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.add(NioEndpoint.java:890)
        at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.longPoll(Http11NioProtocol.java:259)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:722)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1526)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1482)
        - locked Monitor@3d2263f5 at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1481)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
    T37 is created by T30
        at java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:1010)
}}} 

Data race on field org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.cometNotify: {{{
    Concurrent read in thread T30 (locks held: {})
 ---->  at org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.getCometNotify(NioEndpoint.java:1360)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.timeout(NioEndpoint.java:1291)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.run(NioEndpoint.java:1056)
    T30 is created by T1
        at org.apache.tomcat.util.net.NioEndpoint.startInternal(NioEndpoint.java:426)

    Concurrent write in thread T37 (locks held: {Monitor@3d2263f5})
 ---->  at org.apache.tomcat.util.net.NioEndpoint$KeyAttachment.setCometNotify(NioEndpoint.java:1359)
        at org.apache.tomcat.util.net.NioEndpoint.processSocket(NioEndpoint.java:620)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.add(NioEndpoint.java:903)
        at org.apache.tomcat.util.net.NioEndpoint$Poller.add(NioEndpoint.java:890)
        at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.longPoll(Http11NioProtocol.java:259)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:722)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1526)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1482)
        - locked Monitor@3d2263f5 at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1481)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
    T37 is created by T30
        at java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:1010)
}}}
Comment 1 Mark Thomas 2015-09-18 09:00:42 UTC

*** This bug has been marked as a duplicate of bug 58396 ***